jQuery in Action, 2nd edition*
The moose likes JNLP and Web Start and the fly likes How to specify a JRE range in jnlp file? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Java » JNLP and Web Start
Bookmark "How to specify a JRE range in jnlp file?" Watch "How to specify a JRE range in jnlp file?" New topic
Author

How to specify a JRE range in jnlp file?

Vicky Wolf
Greenhorn

Joined: Oct 17, 2008
Posts: 5
We have a java app which uses Java Web Start. The jnlp file is configured with [j2se version="1.5+"]. So if JRE 1.5 and 1.6 are installed, the app is run on 1.6.

Now, we have requirement where the app should be restricted to run only within the range - JRE 1.5.0_07 through JRE 1.5.0_17

[j2se version="1.5*"] will not work - it will always launch the app with the latest jre from 1.5 family.

I can request an exact product version by including the href attribute. [j2se version="1.5.0_14" href="http://java.sun.com/products/autodl/j2se"/]

But how do I specify a specific range of JREs in the jnlp file so that JWS picks up a JRE from that range only? So if 1.5.0_07, 1.5.0_17 and JRE 6 are installed, it should run the app on 1.5.0_17.

Can JNLP really allow you to select specific range of JREs? Is there a good way to accomplish this? Please help.

SCJP 1.4, SCEA 5 (Step 1)
Mike Peters
Ranch Hand

Joined: Oct 10, 2009
Posts: 67

Use multiple entries, for example:



see http://java.sun.com/javase/6/docs/technotes/guides/javaws/developersguide/syntax.html


Mike Peters
 
jQuery in Action, 2nd edition
 
subject: How to specify a JRE range in jnlp file?
 
Similar Threads
Running jdk 1.5 and 1.6
j2se tag with differents versions ????
JDK version vs JRE version
java web start (jre) incompatibilities
jnlp controle version