aspose file tools*
The moose likes Other Java Products and Servers and the fly likes Loopback Url Troubleshooting Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Products » Other Java Products and Servers
Bookmark "Loopback Url Troubleshooting" Watch "Loopback Url Troubleshooting" New topic
Author

Loopback Url Troubleshooting

Bill Riedl
Greenhorn

Joined: Sep 08, 2009
Posts: 4
Hi All,
I have configured a centos 5.4 virtual box to run the liferay portal manager on a Glassfish v2.1 application server. Even though this is not recommended I gave glassfish root privileges and am allowing to listen on port 80.(I did this because of a nightmarish experience with mod_jk although the behavior that was frustrating there is the same behavior I describe below so if I fix this I can go back to an apache front !!) It works locally using the servers ip address in a browser "192.168.xx.xxx/" the liferay welcome screens comes up without delay. However when I try to access the host using its domain name from a web browser not on the internal network the following happens.
I enter "server.institution.edu" and get this --> "server.institution.eduwww.server.institution.edu" There is some type of loopback error

I do believe this pertains to my glassfish install because when I stop glassfish and start apache I can navigate to "server.institution.edu" and see the standard apache "It works!" splash page with no unexpected behavior.

To be complete I added a third http-listener to glassfish which binds port 80 and is set to listen at 0.0.0.0 which is the glassfish shorthand for listening on any IP address bound to the host.

Lastly, I have completely redone iptables with a complete flush and then added the necessary rules back to ensure there was not any redirection occuring.

Thanks for your time! I am stumped on this one!
-JavaEE Newb Bill
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Loopback Url Troubleshooting