aspose file tools*
The moose likes Servlets and the fly likes Servlet /MyAPP threw load() exception: java.lang.Null.PointerException Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Servlets
Bookmark "Servlet /MyAPP threw load() exception: java.lang.Null.PointerException" Watch "Servlet /MyAPP threw load() exception: java.lang.Null.PointerException" New topic
Author

Servlet /MyAPP threw load() exception: java.lang.Null.PointerException

gregg ferguson
Greenhorn

Joined: Aug 05, 2008
Posts: 6
First, thank you for reading this.
Second, if I am in the wrong place (or format/forum) I am sorry and I will correct it.

I am attempting to migrate a J2EE app from Windows Server 2003 R2 to Centos 5.6.
Windows works fine, Centos I have an Error.

Here is the list of components that have changed.
jboss-4.0.1 (Windows) to jboss-6.0.0.20100429-M3 (Linux)
java version 1.6.0_10-beta (Windows) to java version 1.6.0_20 (Linux)

My IDE is MyEclipes 5.5.1 GA
I am using Jakarta Struts 1.2
I am deploying an EAR file

Here is the error I am getting...
ERROR [[/MyAPP]] Servlet /MyAPP threw load() exception: java.lang.NullPointerException

I have increased logging to DEBUG in hopes of getting more info. I did not get more info, or I am reading it correctly.
Where should I start to figure this error out? I can add log files, config files, and code snippets if you would like.

Again I thank you for any help. I really want to figure this out so I can learn, seems I need a push.
Gregg

Bear Bibeault
Author and ninkuma
Marshal

Joined: Jan 10, 2002
Posts: 60055
    
  65

The stack trace for the exception will pinpoint the line where the exception occurred. That's where to start looking.


[Asking smart questions] [Bear's FrontMan] [About Bear] [Books by Bear]
gregg ferguson
Greenhorn

Joined: Aug 05, 2008
Posts: 6
Hmm, Let me see if you can see something I am missing.
Forgive me if I am rely not seeing it. I would expect to see something like
"at com.myapp."...

David Newton
Author
Rancher

Joined: Sep 29, 2008
Posts: 12617

A jump from JBoss 4 to 6 is a big change: start smaller, with a simple servlet app, then a simple S1 app, then start adding things until it breaks.

Also note that JBoss 6 is a milestone release, and as such, may just not work.
gregg ferguson
Greenhorn

Joined: Aug 05, 2008
Posts: 6
Thank you! I will start with the same version of Jboss and slowly move up. This will take me some time,
a few days or so. I will keep you posted. And again thanks for you guidance, as I am trying to learn as
much as possible.
gregg ferguson
Greenhorn

Joined: Aug 05, 2008
Posts: 6
I dropped down to Jboss version 4.0.1 and everything worked. Thanks for all your help!
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Servlet /MyAPP threw load() exception: java.lang.Null.PointerException
 
Similar Threads
Error Validating Axis2 installation
jboss- load on startup problem
JBoss 5.1.0GA to Weblogic 8.1 Bridge - Getting CNFE for weblogic.jndi.WLInitialContextFactory
Why NestedServletException?
Logging problem log4j:ERROR