File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Struts and the fly likes classloader problem in a struts application. Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Frameworks » Struts
Bookmark "classloader problem in a struts application." Watch "classloader problem in a struts application." New topic
Author

classloader problem in a struts application.

Manpreeet Singh
Greenhorn

Joined: Dec 14, 2004
Posts: 2
I am using weblogic for my application and when i start the server and try to access the page,i get classnotfound error.Whereas classpath is set properly(as system variables--i have included struts.jar and other related co--.jars there.).Someone please help.

Error 500--Internal Server Error
javax.servlet.ServletException: [HTTP:101250][ServletContext(id=11086506,name=/,context-path=)]: Servlet class org.apache.struts.action.ActionServlet for servlet action could not be loaded because a class on which it depends was not found in the classpath
-------------------------------....
java.lang.NoClassDefFoundError.
at weblogic.servlet.internal.ServletStubImpl.prepareServlet(ServletStubImpl.java:800)
at weblogic.servlet.internal.ServletStubImpl.getServlet(ServletStubImpl.java:504)
at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:349)
at weblogic.servlet.internal.ServletStubImpl.invokeServlet(ServletStubImpl.java:305)
at weblogic.servlet.internal.WebAppServletContext$ServletInvocationAction.run(WebAppServletContext.java:6310)
at weblogic.security.acl.internal.AuthenticatedSubject.doAs(AuthenticatedSubject.java:317)
at weblogic.security.service.SecurityManager.runAs(SecurityManager.java:118)
at weblogic.servlet.internal.WebAppServletContext.invokeServlet(WebAppServletContext.java:3622)
at weblogic.servlet.internal.ServletRequestImpl.execute(ServletRequestImpl.java:2569)
at weblogic.kernel.ExecuteThread.execute(ExecuteThread.java:197)
at weblogic.kernel.ExecuteThread.run(ExecuteThread.java:170)
Manpreeet Singh
Greenhorn

Joined: Dec 14, 2004
Posts: 2
i finally solved the problem.

It was a conflict of classpaths from system variables and setEnvcmd(Weblogic 8.1)[Result of extra-consciousness for classpath.]

I removed everything in classpath of system variables and it worked.
 
GeeCON Prague 2014
 
subject: classloader problem in a struts application.