aspose file tools*
The moose likes Beginning Java and the fly likes how do save : set path=  permenantly Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Beginning Java
Bookmark "how do save : set path=  permenantly" Watch "how do save : set path=  permenantly" New topic
Author

how do save : set path= permenantly

Dmitri Makovetskiy
Ranch Hand

Joined: Jun 21, 2010
Posts: 128
i can operate "javac" only after i set path=C:\program files\ java

but when i close that dos window, the set path resets itself, and i need to type the whole line again .

how can i make the dos window remember where the java.exe and javac.exe are ? how do i set path , forever?
marc weber
Sheriff

Joined: Aug 31, 2004
Posts: 11343

See step 4 (update the PATH variable) in installation instructions for JDK 6 in Windows (32 bit).


"We're kind of on the level of crossword puzzle writers... And no one ever goes to them and gives them an award." ~Joe Strummer
sscce.org
Dmitri Makovetskiy
Ranch Hand

Joined: Jun 21, 2010
Posts: 128
marc weber wrote:See step 4 (update the PATH variable) in installation instructions for JDK 6 in Windows (32 bit).



okay thanks for the link


damn . i followed step 4, i went to the control panel>system>Environment variable
then i saved a path to program files\java\JDk 1.6.0.1_20 \bin

still doesnt recognize java


abhishek rathur
Ranch Hand

Joined: Jan 14, 2010
Posts: 66
stat->my computer (properties)->advance->enviornment variable->go for uesr variable->new->variable name:path=path-->variable value=D:\Program Files\Java\jdk1.5.0_02\bin;

thats it.....
marc weber
Sheriff

Joined: Aug 31, 2004
Posts: 11343

Dmitri Makovetskiy wrote:...i went to the control panel>system>Environment variable
then i saved a path to program files\java\JDk 1.6.0.1_20 \bin

still doesnt recognize java

Make sure your setting is exactly...

C:\Program Files\Java\jdk1.6.0_20\bin

The snippet you posted is missing "C:\" and has a space after "JDk" and another space after "20". (I don't think the uppercase "JD" should matter, but best to match this to the actual directory name, which is probably lowercase "jdk".)

Also, make sure it is separated from other PATH values by a semicolon with no spaces...

value1;value2;value3;C:\Program Files\Java\jdk1.6.0_20\bin
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: how do save : set path= permenantly