aspose file tools*
The moose likes JBoss/WildFly and the fly likes JBoss 5.1.0 can support struts up to which version ? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "JBoss 5.1.0 can support struts up to which version ?" Watch "JBoss 5.1.0 can support struts up to which version ?" New topic
Author

JBoss 5.1.0 can support struts up to which version ?

Jack Lau
Ranch Hand

Joined: Aug 30, 2002
Posts: 166
Hello,

Does anyone know JBoss 5.1.0 can support struts up to which version (the latest and the oldest)?

Thanks,
Jack
Jack Lau
Ranch Hand

Joined: Aug 30, 2002
Posts: 166
I have checked that JBoss 5.1.0 contains Servlet-api.jar and JSP-api.jar which support struts 2. Base on the website http://struts.apache.org/2.1.8.1/ mentioned

Apache Struts 2 requires:

* Servlet API 2.4
* JSP API 2.0
* Java 5

I think JBoss 5.1.0 can support struts 2.

Am I right ?
Peter Johnson
author
Bartender

Joined: May 14, 2008
Posts: 5837
    
    7

I have seen others post questions related to Struts 2 and JBoss AS 5.1.0, so I would say that it probably supports it. But based on the way you are asking the question I assume that you tried it and ran into problems...


JBoss In Action
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: JBoss 5.1.0 can support struts up to which version ?