aspose file tools*
The moose likes Tomcat and the fly likes Tomcat/6.0 issue with catalina StandardManager Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Tomcat
Bookmark "Tomcat/6.0 issue with catalina StandardManager" Watch "Tomcat/6.0 issue with catalina StandardManager" New topic
Author

Tomcat/6.0 issue with catalina StandardManager

Helen Hatzi
Greenhorn

Joined: Jun 26, 2010
Posts: 2

Hello,

I am developing a web application I used to work with Tomcat 5.5. Recently I tried to upgrade to Tomcat 6 and during startup following error msg appears:

NFO: Starting Servlet Engine: Apache Tomcat/6.0.20
29.06.2010 14:44:52 org.apache.tomcat.util.digester.Digester startElement
SCHWERWIEGEND: Begin event threw error
java.lang.NoClassDefFoundError: org/apache/catalina/session/StandardManager
at java.lang.ClassLoader.findBootstrapClass(Native Method)
at java.lang.ClassLoader.findBootstrapClass0(ClassLoader.java:892)
at java.lang.ClassLoader.loadClass(ClassLoader.java:302)
at java.lang.ClassLoader.loadClass(ClassLoader.java:300)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:301)
at java.lang.ClassLoader.loadClass(ClassLoader.java:300)
at java.lang.ClassLoader.loadClass(ClassLoader.java:252)
at org.apache.tomcat.util.digester.ObjectCreateRule.begin(ObjectCreateRule.java:205)
at org.apache.tomcat.util.digester.Rule.begin(Rule.java:153)


Any clue what the reason for this could be?

Thanks in advance
William Brogden
Author and all-around good cowpoke
Rancher

Joined: Mar 22, 2000
Posts: 12769
    
    5
That class should be in catalina.jar - I would guess either:

1. your installation got trashed somehow and you will have to wipe and try again
2. Some sort of classpath/environment problem is preventing finding the right jar? seems unlikely

Bill
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Tomcat/6.0 issue with catalina StandardManager