File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
The moose likes Distributed Java and the fly likes RMI broken after Ubuntu server upgrade Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Distributed Java
Bookmark "RMI broken after Ubuntu server upgrade" Watch "RMI broken after Ubuntu server upgrade" New topic

RMI broken after Ubuntu server upgrade

Matthew Fleming

Joined: Oct 29, 2009
Posts: 8
I've been using two applets with RMI for several years now. Everything was working fine, until I updated my Ubuntu server, which seems to have changed some sort of security policy, and now they don't work. There are two applets which are downloaded from a server and then connect back to the server via RMI. They talk to two RMI servers which are started like this:

rmiregistry &
java -Xmx512m -classpath dermpathApplet.jar:ilm.jar:mail.jar:activation.jar:mysql-connector-java-5.1.7-bin.jar -Djava.rmi.server.codebase=file:///var/www/regular/htdocs/dermpathApplet.jar -Djava.rmi.server.hostname= com.edermpath.dermpath_client.DPAppletServer &
java -classpath ilm.jar:mysql-connector-java-5.1.7-bin.jar -Djava.rmi.server.codebase=file:///var/www/regular/htdocs/ilm.jar -Djava.rmi.server.hostname= immunolabmanager.ILMServer &

This used to work fine but now I get the following:
at sun.rmi.server.LoaderHandler$
at Method)
at sun.rmi.server.LoaderHandler.getLoaderAccessControlContext(
at sun.rmi.server.LoaderHandler.lookupLoader(
at sun.rmi.server.LoaderHandler.loadProxyClass(
at java.rmi.server.RMIClassLoader$2.loadProxyClass(
at java.rmi.server.RMIClassLoader.loadProxyClass(
at sun.rmi.server.MarshalInputStream.resolveProxyClass(
at sun.rmi.registry.RegistryImpl_Skel.dispatch(Unknown Source)
at sun.rmi.server.UnicastServerRef.oldDispatch(
at sun.rmi.server.UnicastServerRef.dispatch(
at sun.rmi.transport.Transport$
at Method)
at sun.rmi.transport.Transport.serviceCall(
at sun.rmi.transport.tcp.TCPTransport.handleMessages(
at sun.rmi.transport.tcp.TCPTransport$ConnectionHandler.run0(
at sun.rmi.transport.tcp.TCPTransport$
at java.util.concurrent.ThreadPoolExecutor.runWorker(
at java.util.concurrent.ThreadPoolExecutor$
at sun.rmi.transport.StreamRemoteCall.exceptionReceivedFromServer(
at sun.rmi.transport.StreamRemoteCall.executeCall(
at sun.rmi.server.UnicastRef.invoke(
at sun.rmi.registry.RegistryImpl_Stub.rebind(Unknown Source)
at java.rmi.Naming.rebind(
at immunolabmanager.ILMServer.main(
and the same error for the other server.
I tried changing to this:
java -Xmx512m -classpath dermpathApplet.jar:ilm.jar:mail.jar:activation.jar:mysql-connector-java-5.1.7-bin.jar -Djava.rmi.server.codebase=file:///var/www/regular/htdocs/dermpathApplet.jar -Djava.rmi.server.hostname= com.edermpath.dermpath_client.DPAppletServer &
with the following in policy.file:
grant codeBase = "file:///var/www/regular/htdocs/*" {
But this did not help.

The applets are signed. I've never had this kind of problem before and don't know how to fix it. These applets are essential to my business. I'd really, really appreciate some help.

Matthew Fleming, MD
Fleming Dermatopathology
Mike Peters
Ranch Hand

Joined: Oct 10, 2009
Posts: 67

Your problem might be related to

Mike Peters
I agree. Here's the link:
subject: RMI broken after Ubuntu server upgrade
jQuery in Action, 3rd edition