wood burning stoves 2.0*
The moose likes Websphere and the fly likes Websphere and eclipse ? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Websphere
Bookmark "Websphere and eclipse ?" Watch "Websphere and eclipse ?" New topic
Author

Websphere and eclipse ?

Sam Doder
Ranch Hand

Joined: Feb 06, 2008
Posts: 204
Ok, I am having trouble createing a server in eclipse that use's websphere 6.0
I created a dynamic web project as usual and downloaded the websphere connector...etc

When I try to run (run on server button) It gives me a X The server does not support version 3.0 of the J2EE Web module specification.

I don't get it I have jre 6.0 installed for the runtime so it is current /latest runtime enviroment.

I have installed apaches geronimo v2.1 for the server adapters

Thanks for any help.

Basically I was screwing around with creating a deleting server/ adapters (installing new ones ...etc ) and now I am having a problem with getting it to work again thru eclipse.

If I export as a WAR file then upload it in the Web Administrator config page it runs fine. But It is a pain to always have to upload it to websphere every time a change has occured ....etc etc
Would be nice to run it thru eclipse.... the static web projects run fine thru HTTP preview....etc
But the jsp /dynamic web pages must run on a server tomcat , jetty ,...etc server adapters work great however I need to use websphere since my busniess requires it.
I noticed I did delete some things and when I did the geronimo configuration xml file disappeared under the WEB-INF.
Deepak Pant
Ranch Hand

Joined: Feb 13, 2004
Posts: 443
Here is what I know:

1. You can use Eclipse to create jee project. Assemble the code using Ant (from apache) instead of wsant. So create EAR, WAR etc using ant.

2. You can write ant tasks that can automate the project deployment to WAS server. (Application stop/start, install/uninstall etc).

3. You can do remote debugging of the code running in WAS using Eclipse. Run your WAS Server and app and start remote debug from Eclipse.

4. There is no adapter or server connector available for plain Eclipse (including Galileo or Helios), which will allow any kind of admin of WAS 6.x or 7.x. It is offered as premium service from IBM or MyEclipse Blue edition.

Please post here if you end up finding something that is more convenient and works with WAS within plain Eclipse.
Sam Doder
Ranch Hand

Joined: Feb 06, 2008
Posts: 204
I did a reinstall of everything ( reinstalling eclipse , deleteing old eclipse , downloaded the server adapter plugins and it still didn't fix the problems.
Then (I FOUND OUT THAT YOU HAVE TO DELETE THE OLD WORKSPACE/OR CREATE ANOTHER WORKSPACE) Because apparently the new installed eclipse was still using some configurations/plugins from the old workspace that was not allowing me to create a server for WAS. And every project a created in that workspace would not work properly with WAS ,...etc.


I am just wondering are plugins or server adapters specific to a workspaces when you download them? So if you corrupt a plugin/server adapter can you just create another workspace and redownload the plugins/server adapter to fix it? (instead of reinstalling the whole eclipse again)

Thanks

Deepak Pant
Ranch Hand

Joined: Feb 13, 2004
Posts: 443
Are you using WAS Community Edition? I am not aware of any plug in for WAS Base or ND server for 6.1 and above versions. Can you share the download links for plug-in/adapters? Thanks
Sam Doder
Ranch Hand

Joined: Feb 06, 2008
Posts: 204
WAS Community Edition

Yes I am using the community edition.

WASCE server adapters ,...etc

 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Websphere and eclipse ?
 
Similar Threads
Add WAS 6.1 runtime to eclipse 3.5?
WAS 7.0 with Eclipse 3.5 and Installation Issue?
Why do my JARs have to be in the server classpath?
Websphere 6 and IBM webserver
trouble with geronimo plugin for eclipse