Win a copy of Design for the Mind this week in the Design forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Jasper Report fond can't change into bold?

 
Kaustubh G Sharma
Ranch Hand
Posts: 1283
Chrome Java Netbeans IDE
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi i am working with jasper ireport where i am using some parameters and want that parameter in bold i used the bold option on that parameter but when the final report generated the font not find in bold..

help me out???

thanks

kaustubh
 
Kaustubh G Sharma
Ranch Hand
Posts: 1283
Chrome Java Netbeans IDE
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
the problem not solved it yet I tried to do everything may be it generate some log file so using that only or jasper tool having some problem with it..
 
bilal sidiqui
Author
Greenhorn
Posts: 17
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Is it possible for you to post the JRXML that you are using to show a parameter in bold? The correct JRXML will be something like the following:



Assuming you are using iReport, when you drop a parameter into your report, what you see in the report is a field associated with a parameter. If you check “Bold” property of the field, it should show as bold.

By the way my JasperReports book has more than a dozen of such examples.
 
Kaustubh G Sharma
Ranch Hand
Posts: 1283
Chrome Java Netbeans IDE
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Bilal thanks for reply well as xml code you posted in the refrence for my question...I am doing the same with my reports...everything is fine from coding side but when the final output came of this will not reflect those changes in it..May it saves the old fine in some logs and after every call it calls that file only I am not able to figure out the problem...

You can see the propety of my file below


Thanks
Kaustubh
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic