File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Java in General and the fly likes java.lang.IllegalAccessError: tried to access field Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » Java in General
Bookmark "java.lang.IllegalAccessError: tried to access field" Watch "java.lang.IllegalAccessError: tried to access field" New topic
Author

java.lang.IllegalAccessError: tried to access field

olze oli
Ranch Hand

Joined: Jun 20, 2009
Posts: 148
hi,

i have a little application which uses htmlunit.
but htmlunit is extremly slow so i thought i download the source, change the code in htmlunit where the httpclient is created and use it in my app (i know that the httpclient is much faster sending POST than the htmlunit, but htmlunit has js support, thats the reason why i use htmlunit and not only httpclient)
the httpclient is in a file called HttpWebConnection.java
private AbstractHttpClient httpClient_;

so i thought i change it to public, and access it:
response = conn.httpClient_.execute(httppost);

but now i get an error:
Exception in thread "Thread-3" java.lang.IllegalAccessError: tried to access field com.gargoylesoftware.htmlunit.HttpWebConnection.httpClient_ from class Groove.Client
at Groove.Client.sendRequest(Client.java:419)
at Groove.Client.getShort(Client.java:454)
at Groove.Client.connect(Client.java:200)
at Groove.Client.getInstance(Client.java:89)
at Groove.browser.GrooveView$6.run(ClientView.java:332)

what does that mean?
i also tried it with a getter method but i get the same error
Janeice DelVecchio
Saloon Keeper

Joined: Sep 14, 2009
Posts: 1660
    
  11

Seems to me this might be too difficult for a beginner forum. Let's see if you get more responses in the general forum...


When you do things right, people won't be sure you've done anything at all.
Poobhathy Kannan
Ranch Hand

Joined: May 26, 2004
Posts: 94
What i can think of is jar file or the classes loaded at runtime. It may still refer to the old classes. As you have changed the code, please check whether only the modified classes are loaded at runtime


http://learnertobeginner.blogspot.com/
olze oli
Ranch Hand

Joined: Jun 20, 2009
Posts: 148
thanks alot! you have been right, i forgot to delete the .jar
its working now, thanks
 
Don't get me started about those stupid light bulbs.
 
subject: java.lang.IllegalAccessError: tried to access field