wood burning stoves 2.0*
The moose likes Struts and the fly likes Please Help with this Hyperlink question Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "Please Help with this Hyperlink question" Watch "Please Help with this Hyperlink question" New topic
Author

Please Help with this Hyperlink question

nash avin
Ranch Hand

Joined: Nov 18, 2004
Posts: 45
Hi All,
In the index.jsp page there is this below line , accordingly it should give a hyperlink, but i am not getting the hyperlink.What could be the problem.


<html:link page="/do/setupStudentForm">Add a Student</html:link>

index.jsp code follows.....





What could be the problem,,kindly let me know in as much detail as possible.

Thanking you all
AS
Jason Menard
Sheriff

Joined: Nov 09, 2000
Posts: 6450
When you "View Source" on the web page that has been generated from your JSP, that is, when you are looking at it in your browser while the application is running, do you see:

<html:link page="/do/setupStudentForm">Add a Student</html:link>

If this is the case and the tag is not being processed correctly, if it's being ignored when the JSP is compiled, then my best guess is that you have not specified this tag library in the web.xml file.

If on the other hand you are getting an error, you will need to post that error in order for us to have a chance of figuring it out.
nash avin
Ranch Hand

Joined: Nov 18, 2004
Posts: 45
Hi ,
Thanks a lot for the reply.I did not get an error in either the log file or the browser.I will try as you have told, and get back.Thanks again

AS
nash avin
Ranch Hand

Joined: Nov 18, 2004
Posts: 45
/**** This is the response I got for the posted question******/


When you "View Source" on the web page that has been generated from your JSP, that is, when you are looking at it in your browser while the application is running, do you see:

<html:link page="/do/setupStudentForm">Add a Student</html:link>

If this is the case and the tag is not being processed correctly, if it's being ignored when the JSP is compiled, then my best guess is that you have not specified this tag library in the web.xml file.

If on the other hand you are getting an error, you will need to post that error in order for us to have a chance of figuring it out.


/**** This is the response I got for the posted question******/

This is my web.xml, inside the Application, I have created just in case

Marc Peabody
pie sneak
Sheriff

Joined: Feb 05, 2003
Posts: 4727

Is struts-html-el.tld in your WEB-INF folder?

Also, you probably want the attribute of the tag to be action rather than page.


A good workman is known by his tools.
nash avin
Ranch Hand

Joined: Nov 18, 2004
Posts: 45
Hi,
Thanks for the reply.I do have struts-html-el.tld file in my WEB-INF directory.But still I am not able to get the link over "add a student".
When you said that tag should be in action rather than page I didnt quite understand what you ment.It would be great if you can explain it in detail.

Thanks again for the help
AS
Marc Peabody
pie sneak
Sheriff

Joined: Feb 05, 2003
Posts: 4727

You know, now that I think of it... it doesn't make much difference.

BTW, wouldn't

do the same thing?
nash avin
Ranch Hand

Joined: Nov 18, 2004
Posts: 45
Hi,
Thanks for the suggestion.I did get it to work.

AS
 
 
subject: Please Help with this Hyperlink question