This week's giveaway is in the EJB and other Java EE Technologies forum.
We're giving away four copies of EJB 3 in Action and have Debu Panda, Reza Rahman, Ryan Cuprak, and Michael Remijan on-line!
See this thread for details.
The moose likes Struts and the fly likes validator problems, clientside = ok, serverside = not working Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "validator problems, clientside = ok, serverside = not working" Watch "validator problems, clientside = ok, serverside = not working" New topic
Author

validator problems, clientside = ok, serverside = not working

mark chester
Greenhorn

Joined: Feb 03, 2005
Posts: 3
Hi Folks,

I'm currently developing a web app using struts 1.1. I'm using the validator plugin to do required, mask (alphanumeric only) and maxlength (8) checks on one of my form fields.

I have also added the required tags to my jsp to get this validation to work on the client side. All three of these checks work fine on the client side but if I turn off javascript only the 'required' check on the server side seems to work. And forms with invalid characters and long fields are passed to my action class!

This is really strange, if anything I would expect problems on the client side! - I'm pretty sure my validation and struts-config files are okay? any ideas?

Could this be a bug perhaps?
 
wood burning stoves
 
subject: validator problems, clientside = ok, serverside = not working
 
Similar Threads
Dynavalidation, and problems with.
Struts-Validation For Disabled Fields
Bypass client-side struts validation
struts validator. stoping on first validation error.
Validation of select boxes using struts validator