File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes JSP and the fly likes JSP page not getting displayed on linux machine browser Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Java » JSP
Bookmark "JSP page not getting displayed on linux machine browser" Watch "JSP page not getting displayed on linux machine browser" New topic
Author

JSP page not getting displayed on linux machine browser

Adi Kulkarni
Ranch Hand

Joined: Mar 12, 2009
Posts: 86
Hello,

We have an application deployed on a linux machine. A particular JSP page in the application is not getting displayed at all. The page is getting displayed properly on a windows machine and browser.

Also there are no exceptions seen in the logs.

What could be the possible issue ? Are there any check points using which we can debug this issue ?

Kindly help.

Thanks,
Aditya


SCJP 1.5
Richard Golebiowski
Ranch Hand

Joined: May 05, 2010
Posts: 213

When you say there are no exceptions shown in the logs, what logs are you looking at?

Have you tried a different browser on the Linux machine?

Would it be possible to substitute the JSP page in question with another page or eliminate parts of the JSP page in question to rule out problems with the page?

Adi Kulkarni
Ranch Hand

Joined: Mar 12, 2009
Posts: 86
Hello Richard,

The entire java code in the JSP is inside a try /catch block. So by logs I mean that there is no exception thrown . Also, the linux machine in question is a remote one which I cant access.

The JSP in question is working fine on our setups.

Is there anything in particular which needs to be checked while working with linux ?

Thanks,
Aditya
Richard Golebiowski
Ranch Hand

Joined: May 05, 2010
Posts: 213

I don't think it would be anything to do with a server running on Linux.

Can you provide more details about the setups, the ones that you say are working and the ones that aren't?

What are you using for a web server?

When you say it works fine in your setups, is it also on a Linux box?

Adi Kulkarni
Ranch Hand

Joined: Mar 12, 2009
Posts: 86
Hello Richard,

Following are the details:

1: Webserver : IBM WebSphere.
2: The setup is on a Windows box.

Also , one thing here is that, the other JSP pages are getting displayed on the linux box except a single JSP page. After putting System.out's we came to know that the logic is running fine, the query is returning proper results but it is not getting displayed at all.

The same page is getting displayed on our windows setup.

So what I think is that the issue might be with the displaying logic. But since its working on other setup we're not able to find the exact reason why it might not be working on the linux browser.


Thanks,
Aditya
Richard Golebiowski
Ranch Hand

Joined: May 05, 2010
Posts: 213

What browser are you using on the Linux box?

Can you try a different browser?

The only time I ever ran into a problem on my Linux box was on a web site that was doing some checking on what browser I was using.
Adi Kulkarni
Ranch Hand

Joined: Mar 12, 2009
Posts: 86
Hello Richard,

Actually the same page is getting displayed for a different condition. But this condition isn't the problem according to us.

It is actually puzzling since we're not getting any leads as to what the real issue might be.

Since all the other pages are getting displayed, trying a different browser shouldn't be justifiable.

Thanks,
Aditya
Gajendra Tomer
Ranch Hand

Joined: Sep 22, 2008
Posts: 32
Hi Adi !

I think you need to do comparative analysis between pages that are working fine and those not working at all.

Or else you can try to execute the problematic page code , segment by code segment from beginning till end and identify the segment with which it's not working fine.

Gajendra ,
Adi Kulkarni
Ranch Hand

Joined: Mar 12, 2009
Posts: 86
Hello,

Just tried step by step. Now if I only display the basic headers and footers etc , the page is getting displayed. After this when I include a statement "JSP Include" and try , the page is not getting displayed.

This JSP include calls a servlet and further a .java file which executes the backend logic and retrieves the records.

So since this is working on windows machine, is there some translation issue on the linux machine? Other pages are working fine with similar changes.

Thanks,
Aditya
Sanjeev P Kulkarni
Greenhorn

Joined: Nov 08, 2009
Posts: 20

I don't think that is a problem with linux. Java itself is written as "Write once run any where". I use Ubuntu to code and upload to the server and the same can be accessed by any operating system either it's windows or linux or mac. Please try to cross check your jsp code.


Sanjeev
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: JSP page not getting displayed on linux machine browser