aspose file tools*
The moose likes BEA/Weblogic and the fly likes Deploying a Struts application on Weblogic 10.3.3 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Products » BEA/Weblogic
Bookmark "Deploying a Struts application on Weblogic 10.3.3" Watch "Deploying a Struts application on Weblogic 10.3.3" New topic
Author

Deploying a Struts application on Weblogic 10.3.3

Vivek Alampally
Ranch Hand

Joined: Jul 10, 2008
Posts: 67
Hi everyone,

I am trying to deploy a web application on weblogic app server. It is working on Tomcat as expected. But when I try to deploy on weblogic server I am getting
the following error.
Error 404--Not Found

From RFC 2068 Hypertext Transfer Protocol -- HTTP/1.1:

10.4.5 404 Not Found

The server has not found anything matching the Request-URI. No indication is given of whether the condition is temporary or permanent.

If the server does not wish to make this information available to the client, the status code 403 (Forbidden) can be used instead. The 410 (Gone) status code SHOULD be used if the server knows, through some internally configurable mechanism, that an old resource is permanently unavailable and has no forwarding address.


I am using Myeclipse 7.5.

The way I deployed web application is

Step1: I downloaded weblogic 11gR1 from Oracle site and installed it on my windows XP pro machine.
Step 2: Then I opened Weblogic's configuration wizard and did some settings
Step3: Then I went to MyEclipse->preferences->Myeclipse Enterprise workbench-> Servers->Weblogic 10.x and I set the properties as

BEA Home directory: C:\bea
WebLogic Installation directory:C:\oracle\Middleware\wlserver_10.3
Administration Username: weblogic(same as given in step 2)
Password: vivek123 (same as given in step 2)
Execution domain root: C:\oracle\Middleware\user_projects\domains\base_domain
Execution server name: AdminServer
security policy file:
JAAS login file:


And, I added the project to weblogic 10.x server.
Then I have started the server and when I entered http://ganapathi:7001/StrutsExample1/index.jsp, I got the above message.

Can anyone here please help me to resolve this issue?

Thanks
Vivek

spipe pic
Greenhorn

Joined: Aug 03, 2010
Posts: 4
have you already try to access to administration console

http://ganapathi:7001/console
thats the first step
Vivek Alampally
Ranch Hand

Joined: Jul 10, 2008
Posts: 67
yes i tried accessing http://ganapathi:7001/console . it is asking a username & password I supplied them and this lets me into Admin console. Then what??
Vivek Alampally
Ranch Hand

Joined: Jul 10, 2008
Posts: 67
Can any body here please tell me what should be configuration for
BEA Home directory:
in case of BEA weblogic 10.3.3?

Thanks,
Vivek
Joe Ess
Bartender

Joined: Oct 29, 2001
Posts: 8927
    
    9

Vivek Alampally wrote:yes i tried accessing http://ganapathi:7001/console . it is asking a username & password I supplied them and this lets me into Admin console. Then what??


On the left hand side of the console, click on "deployments". A list of deployed applications will be displayed. If your application is not displayed, you have a deployment problem. If it is displayed, click on it. When the application page is displayed, click on the "testing" tab. That tab should give you a link to the application home page.


"blabbing like a narcissistic fool with a superiority complex" ~ N.A.
[How To Ask Questions On JavaRanch]
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Deploying a Struts application on Weblogic 10.3.3