aspose file tools*
The moose likes JBoss/WildFly and the fly likes Unable stop JBOSS running in DEBUG mode Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of EJB 3 in Action this week in the EJB and other Java EE Technologies forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "Unable stop JBOSS running in DEBUG mode" Watch "Unable stop JBOSS running in DEBUG mode" New topic
Author

Unable stop JBOSS running in DEBUG mode

raghum Kambaiah
Greenhorn

Joined: Aug 04, 2010
Posts: 3
Friends, I am system admin for a PDM application, and using JBOSS for web app server

I am facing a issue on my Solaris webserver where JBOSS is running, some how it's starting in DEBUG mode, please check execept from server.log

* I checked log4j.xml and there no "DEBUG" levels, all teh log levels are set to "INFO"
* Checked my run.sh/run.conf, there no debug set in JAVAOPT

here is how my server.log appears, currenly this is production issue where the JBOSS log is consuming tons of space allocated for logs, can you guys help me how i can disable the DEBUG mode



2010-08-03 14:10:42,064 DEBUG [org.jboss.web.WebService] Created jboss:service=WebService
2010-08-03 14:10:42,065 DEBUG [org.jboss.system.ServiceController] Creating dependent components for: jboss:service=WebService dependents are: []
2010-08-03 14:10:42,065 DEBUG [org.jboss.system.ServiceController] Creating service jboss:service=Naming
2010-08-03 14:10:42,066 DEBUG [org.jboss.system.ServiceController] Ignoring create request for service: jboss:service=Naming
2010-08-03 14:10:42,067 DEBUG [org.jboss.system.ServiceController] Creating service jboss:service=JNDIView
2010-08-03 14:10:42,068 DEBUG [org.jboss.naming.JNDIView] Creating jboss:service=JNDIView
2010-08-03 14:10:42,068 DEBUG [org.jboss.naming.JNDIView] Created jboss:service=JNDIView
2010-08-03 14:10:42,069 DEBUG [org.jboss.system.ServiceController] Creating dependent components for: jboss:service=JNDIView dependents are: []
2010-08-03 14:10:42,069 DEBUG [org.jboss.system.ServiceController] Creating service jboss.security:service=SecurityConfig
2010-08-03 14:10:42,070 DEBUG [org.jboss.security.plugins.SecurityConfig] Creating jboss.security:service=SecurityConfig
2010-08-03 14:10:42,070 DEBUG [org.jboss.security.plugins.SecurityConfig] Created jboss.security:service=SecurityConfig
2010-08-03 14:10:42,071 DEBUG [org.jboss.system.ServiceController] Creating dependent components for: jboss.security:service=SecurityConfig dependents are: []
2010-08-03 14:10:42,071 DEBUG [org.jboss.system.ServiceController] Creating service jboss.security:service=XMLLoginConfig
2010-08-03 14:10:42,072 DEBUG [org.jboss.security.auth.login.XMLLoginConfig] Creating jboss.security:service=XMLLoginConfig
2010-08-03 14:10:42,072 DEBUG [org.jboss.security.auth.login.XMLLoginConfig] Created jboss.security:service=XMLLoginConfig
2010-08-03 14:10:42,073 DEBUG [org.jboss.system.ServiceController] Creating dependent components for: jboss.security:service=XMLLoginConfig dependents are: []
2010-08-03 14:10:42,073 DEBUG [org.jboss.system.ServiceController] Creating service jboss.security:service=JaasSecurityManager
2010-08-03 14:10:42,074 DEBUG [org.jboss.security.plugins.JaasSecurityManagerService] Creating jboss.security:service=JaasSecurityManager
2010-08-03 14:10:42,074 DEBUG [org.jboss.security.plugins.JaasSecurityManagerService] Created jboss.security:service=JaasSecurityManager
2010-08-03 14:10:42,075 DEBUG [org.jboss.system.ServiceController] Creating dependent components for: jboss.security:service=JaasSecurityManager dependents are: []
2010-08-03 14:10:42,075 DEBUG [org.jboss.system.ServiceController] Creating service jboss:service=XidFactory
2010-08-03 14:10:42,081 DEBUG [org.jboss.system.ServiceController] Creating dependent components for: jboss:service=XidFactory dependents are: [ObjectName: jboss:service=TransactionManager
state: CONFIGURED
I Depend On: jboss:service=XidFactory



Checked with all the available search methods in goole for some solution no sucess yet , Need some urgent help
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 9315
    
109

Which version of JBoss AS is this and what are the contents of JBOSS_HOME/server/< servername>/conf/*-log4j.xml?

While posting logs, xml or code, please wrap it in a code block (you can use the Code button in the editor window). Also please use the Preview button to make sure your post is correctly formatted


[My Blog] [JavaRanch Journal]
Aneesh Vijendran
Ranch Hand

Joined: Jun 29, 2008
Posts: 125
Kill it.

Grep the process Jboss (Sometime you have to grep for java)

ps -aux |grep Jboss

Find the process id and then kill it.

Probably the issue might be as you have started in Debug mode the RMI server is also started for remote debugging.

Cheers
Aneesh


Cheers
Aneesh
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 9315
    
109

From what I understand of the original post from Raghum, he's concerned with the DEBUG level logs. Although yes, the title of this thread is confusing.
Aneesh Vijendran
Ranch Hand

Joined: Jun 29, 2008
Posts: 125
Jaikiran Pai wrote:From what I understand of the original post from Raghum, he's concerned with the DEBUG level logs. Although yes, the title of this thread is confusing.


Thanks Jaikiran for pointing the mistake.

Raghu - I guess you need to open the conf/log4j.xml and find the category for "org.jboss" (As this category is logged with Debug), Then Turn the DEBUG to ERROR

If you don't have that category, Create one and do the same.

Also check for all DEBUG's inside the conf/log4j.xml and change it to ERROR.

Take backup before you do it.

Cheers
Aneesh
raghum Kambaiah
Greenhorn

Joined: Aug 04, 2010
Posts: 3
Friends, SOrry for delay since the server is in production i can only do testing during early hours

- I stopped the JBOSS completely
-I changed everything in log4j.xml from "DEBUG" to "ERROR", attached log4.xml in .txt format fro exper review,
- Rstarted the service
- Here is the JBOSS statup from nohup.out

-

- This how my server.log looks now, and as you can see it's still running in "DEBUG" mode



I am still unable to stop JBOSS staring in DEBUG, i want this to be running on INFO or ERROR

attached log4j.xml for expert review

Aneesh Vijendran
Ranch Hand

Joined: Jun 29, 2008
Posts: 125
You still have the following:


Change them to ERROR

Also make sure the follwing is uncommented from the above:



..and made ERROR as well.

Restart the server. This should work.



raghum Kambaiah
Greenhorn

Joined: Aug 04, 2010
Posts: 3
Hello Aneesh

Thanks for Quick reply, i did changed the log4j.xml and restarted the service, here is latest xml file



Latest server.log, just now taken from server after restart


Stilll not solved
Aneesh Vijendran
Ranch Hand

Joined: Jun 29, 2008
Posts: 125
Mate - Why don't you read my posts clearly?

I had clearly told to remove the comments from:



When I say comments: <-- --> is what I meant.

How do you expect this to work when you comment this category?

 
 
subject: Unable stop JBOSS running in DEBUG mode
 
Similar Threads
CommunicationException in war file deployment
can not deploy application!!!!
JNDI Port number issue while strating JBoss server 4.2.2.GA
EJB30-JBOSS sample tutorial doesn't works!!
Newbie to JBoss