• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

org.apache.jasper.JasperException: Failed to load or instantiate TagLibraryValidator class: org.apa

 
Dibyendu Sarkar
Greenhorn
Posts: 25
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm getting this exception. My project settings are given below. Someone please help me figure out what am I doing wrong. I've tried to provide as much information as I can. Please let me know if any other information is required to help me troubleshoot this.



POM dependencies:



JSP:




TOMCAT: 5.5.17



WEB.XML


MAVEN BUILT PROJECT:


 
Bear Bibeault
Author and ninkuma
Marshal
Pie
Posts: 64718
86
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
It's WEB-INF/lib not LIB.
 
Dibyendu Sarkar
Greenhorn
Posts: 25
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Bear Bibeault wrote:It's WEB-INF/lib not LIB.


Yes, it is lib. I've edited my original post.
 
Bear Bibeault
Author and ninkuma
Marshal
Pie
Posts: 64718
86
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
What else ends up in WEB-INF/lib? Are the servlet and JSP API jars being copied there? They should not be.
 
Dibyendu Sarkar
Greenhorn
Posts: 25
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Bear Bibeault wrote:What else ends up in WEB-INF/lib? Are the servlet and JSP API jars being copied there? They should not be.


No those 2 files are not there. I'm using maven and the scope for those two is set to "provided". There are a bunch of other jars but those are related to CXF and some other stuff and not to JSP/JSTL.
 
Dibyendu Sarkar
Greenhorn
Posts: 25
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm still battling this one. Anyone care to help?

The final built war file (generated using maven) runs fine now when deployed on tomcat 6 installation using the tomcat manager. But inside Eclipse it still refuses to cooperate!
 
Bear Bibeault
Author and ninkuma
Marshal
Pie
Posts: 64718
86
IntelliJ IDE Java jQuery Mac Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Please be sure to post Eclipse questions in the IDEs forum. I have moved this there for you.
 
Dibyendu Sarkar
Greenhorn
Posts: 25
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Bear Bibeault wrote:Please be sure to post Eclipse questions in the IDEs forum. I have moved this there for you.



Well, I thought about it but the error is still the same as the original in the title. It's pretty much a JSTL issue still. So didn't make sense to me to move it from JSP to IDE forum. But anyway, as long as someone is able to help...
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic