aspose file tools*
The moose likes JSF and the fly likes JSF 1.1 and Tomcat 6 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Soft Skills this week in the Jobs Discussion forum!
JavaRanch » Java Forums » Java » JSF
Bookmark "JSF 1.1 and Tomcat 6" Watch "JSF 1.1 and Tomcat 6" New topic
Author

JSF 1.1 and Tomcat 6

Chris Ma
Greenhorn

Joined: Aug 11, 2010
Posts: 1
Hello,

I don't know if this issue was already discussed, but I'm porting my application from Tomcat 5.5.25 to Tomcat 6.0.26 and I'm using JSF 1.1.
I encountered problems when receiving events for Tree element. The return value for getSelected() method of Tree object is null. I tried to use other get methods from Tree class and all return null: getSubmittedValue(), getCookieSelectedTreeNode().
Did anyone encounter this problem?
Do you know if are there any incompatibility issues between Tomcat 6 and JSF1.1?

Thank you.
Tim Holloway
Saloon Keeper

Joined: Jun 25, 2001
Posts: 16303
    
  21

Welcome to the JavaRanch, Chris!

Most likely you've got an el-impl.jar in your WAR. It was required for Tomcat 5.5, but it's now integrated into the libs directory in Tomcat6. That's the same libs directory that replaced the 3 separate libs directories in Tomcat 5 and earlier.

If you remove that jar from your WAR, it will probably work.


Customer surveys are for companies who didn't pay proper attention to begin with.
navdeep thakur
Greenhorn

Joined: May 09, 2007
Posts: 18

Hi Guys,

i have a web application "MF" which was developed with:

1. JSF 1.1
2. MyFaces 1.1.4
3. XML Digester
5. JDK 5
6. Tomcat 5.5.26

Now, I have upgraded my system to Tomcat 6.0.29 and JDK 6, because of another application which is developed with RichFaces 3.3.3, JSF 1.2.

I am trying to deploy "MF" on the new environment i.e. Tomcat 6.0.29 and JDK 6.


I faced following error..

Tomcat Console Logs..



Here is my Web.xml




Even I also tried to upgrade JSF, Myfaces version, but still no luck so far.

Do you guys have any idea?

-
Navdeep


Navdeep Thakur alias Navi
Tim Holloway
Saloon Keeper

Joined: Jun 25, 2001
Posts: 16303
    
  21

It appears you have a custom security module implemented as a servlet filter. Or, more accurately, the web.xml file refers to one. But that class doesn't appear to be present in your WAR.

It's likely that someone had installed it in one of the Tomcat5 library directories and it wasn't copied into the Tomcat 6 library directory.

I wouldn't expect that there would be a problem if you did that, but one of the major differences between Tomcat6 and Tomcat6 is the elimination of the 3-library setup in favor of a single library, so I'd check the vendor documentation to see if there are any issues.
navdeep thakur
Greenhorn

Joined: May 09, 2007
Posts: 18

Hi Tim,

thanks for quick reply.

Well I am facing the same error while deploying this project on My Eclipse.

And that com.gracenote.messaging.auth.UserAuthenticationFilter exist in the appropriate package.

I have done most of the possible tried, but didnt resolved.
Tim Holloway
Saloon Keeper

Joined: Jun 25, 2001
Posts: 16303
    
  21

If MyEclipse is doing anything like what gets done by Eclipse WTP - or worse yet, if MyEclipse uses WTP, it may not be pulling in everything you think it is.

That's why I hate WTP. Unlike the sysdeo plugin, WTP doesn't simply use Tomcat "as is". It selectively pulls parts of Tomcat in while ignoring other parts. Sometimes those ignored parts are important.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: JSF 1.1 and Tomcat 6