aspose file tools*
The moose likes Other Open Source Projects and the fly likes OpenAM on Apache Tomcat 6 Configuration problem. Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Products » Other Open Source Projects
Bookmark "OpenAM on Apache Tomcat 6 Configuration problem." Watch "OpenAM on Apache Tomcat 6 Configuration problem." New topic
Author

OpenAM on Apache Tomcat 6 Configuration problem.

Anthony Mag
Greenhorn

Joined: Nov 27, 2008
Posts: 14
Hi, I deployed OpenAM on tomcat 6, and got the initial configuration screen. But when I try to complete the installation i get the following error output on console :-



I'm not sure what the next step should be towards its resolution, the OpenAM install log, does not show any error details.



[Thumbnail for OpenAMprob.jpg]


Anthony G,
http://www.mysuccessmantra.com
Tweet @ tonygcal
Anthony Mag
Greenhorn

Joined: Nov 27, 2008
Posts: 14
Hi all, 2 days no pointers, im still stuck with this. Need some inputs.
Regards,
Anthony.
Anthony Mag
Greenhorn

Joined: Nov 27, 2008
Posts: 14
Hi, since I didn't get any replies, decided 2 do some R&D and find out the solution. Here is how it works out :-
The problem was with the CATALINA_OPTS properties. Seems like OpenAM needs at least 1G heap size.
If you dont have access to tomcat6w gui, create a setenv.bat file in /bin for the server and enter :-
set CATALINA_OPTS=-Xms512m -Xmx1024m

That should suffice. Also set the same for JAVA_HOME through control panel properties.
Regards.
Reetesh Singh
Greenhorn

Joined: Aug 08, 2012
Posts: 1
i came across this issue. I followed steps mentioned in this link.: -
1.created setenv.bat with mentioned entry.
2.then started tomcat. still i am getting same problem during default configuration.

ques:-
1. do we need to set CATALINA_OPTS as environment var.
2. if no , then how does startup.bat will pick entry of setenev.bat


Please let me know your if i have gone ahead with any wrong steps.

Thanks,
Reetesh
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: OpenAM on Apache Tomcat 6 Configuration problem.