Win a copy of Design for the Mind this week in the Design forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Newbie can't run Ruby in debug, help!

 
Jane Jukowsky
Ranch Hand
Posts: 157
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
C:/Ruby191/lib/ruby/gems/1.9.1/gems/ruby-debug-base-0.10.3-x86-mswin32/lib/ruby-debug-base.rb:1:in `require': 126: The specified module could not be found. - C:/Ruby191/lib/ruby/gems/1.9.1/gems/ruby-debug-base-0.10.3-x86-mswin32/lib/ruby_debug.so (LoadError)
from C:/Ruby191/lib/ruby/gems/1.9.1/gems/ruby-debug-base-0.10.3-x86-mswin32/lib/ruby-debug-base.rb:1:in `<top (required)>'
from C:/Ruby191/lib/ruby/gems/1.9.1/gems/ruby-debug-ide-0.4.5/lib/ruby-debug.rb:5:in `require'
from C:/Ruby191/lib/ruby/gems/1.9.1/gems/ruby-debug-ide-0.4.5/lib/ruby-debug.rb:5:in `<top (required)>'
from C:/Ruby191/lib/ruby/gems/1.9.1/gems/ruby-debug-ide-0.4.5/bin/rdebug-ide:6:in `require'
from C:/Ruby191/lib/ruby/gems/1.9.1/gems/ruby-debug-ide-0.4.5/bin/rdebug-ide:6:in `<top (required)>'
from C:/Ruby191/bin/rdebug-ide:19:in `load'
from C:/Ruby191/bin/rdebug-ide:19:in `<main>'


The ruby.debug.so and ruby-debug-base.rb exist. What's up with that?
 
Marc Peabody
pie sneak
Sheriff
Posts: 4727
Mac Ruby VI Editor
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Googling gave me results of a few threads like this one that may be helpful:

http://old.nabble.com/Ruby-Debugger-not-working-td27847083.html
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic