wood burning stoves*
The moose likes Websphere and the fly likes 404 Error on web application Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "404 Error on web application" Watch "404 Error on web application" New topic
Author

404 Error on web application

Brian McCullars
Greenhorn

Joined: Aug 16, 2010
Posts: 1
I am trying to install a web application to WebSphere Application Server Community edition. Here my configs are below. The application installs just fine except for the following message in the logs:

2010-08-16 11:54:54,421 ERROR [TomcatContainer] Unable to add the child container: /myurl . Please check if your project's context-root is unique.

When try to execute the url I get a 404 error in the browser.

Any ideas what the problem is?

geronimo-application.xml
<application application-name="myEar"
xmlns="http://geronimo.apache.org/xml/ns/j2ee/application-2.0"
xmlns:security="http://geronimo.apache.org/xml/ns/security-2.0"
xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.2">
<dep:environment>
<dep:moduleId>
<dep:groupId>myEAP</dep:groupId>
<dep:artifactId>myEar</dep:artifactId>
<dep:version>1.0</dep:version>
<dep:type>car</dep:type>
</dep:moduleId>
<dep:dependencies>
<dep:dependency>
<dep:groupId>org.apache.geronimo.framework</dep:groupId>
<dep:artifactId>j2ee-security</dep:artifactId>
<dep:type>car</dep:type>
</dep:dependency>
</dep:dependencies>
<dep:hidden-classes/>
<dep:non-overridable-classes />
</dep:environment>
<security:security>
<security:role-mappings>
<security:role role-name="myUserRole">
<security:realm realm-name="custom-realm">
<security:principal
class="org.apache.geronimo.security.realm.providers.GeronimoUserPrincipal"
name="guest" />
</security:realm>
</security:role>
</security:role-mappings>
</security:security>
</application>

geronimo-web.xml
<?xml version="1.0" encoding="UTF-8"?>
<web-app xmlns="http://geronimo.apache.org/xml/ns/j2ee/web-2.0.1"
xmlns:naming="http://geronimo.apache.org/xml/ns/naming-1.2">
<dep:environment xmlns:dep="http://geronimo.apache.org/xml/ns/deployment-1.2">
<dep:moduleId>
<dep:groupId>myapp</dep:groupId>
<dep:artifactId>myWar</dep:artifactId>
<dep:version>1.0</dep:version>
<dep:type>war</dep:type>
</dep:moduleId>
<dep:dependencies>
<dep:dependency>
<dep:groupId>console.dbpool</dep:groupId>
<dep:artifactId>MyDataSource</dep:artifactId>
</dep:dependency>
</dep:dependencies>
<dep:hidden-classes />
<dep:non-overridable-classes />
</dep:environment>
<context-root>/myurl</context-root>
<security-realm-name>custom-realm</security-realm-name>
<resource-ref>
<ref-name>com/anthem/corp/bms/jdbc/mssql</ref-name>
<resource-link>MyDataSource</resource-link>
</resource-ref>
</web-app>
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: 404 Error on web application
 
Similar Threads
Application stopped during the DBpool deployment
Connection Pool (couldn't find datasource)
Help executing an EJB persistence application
HTTP status 404 error
Trying EJB3 from Eclipse WTP Book