jQuery in Action, 3rd edition
The moose likes Websphere and the fly likes SOAP header missing from the message? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login

Win a copy of REST with Spring (video course) this week in the Spring forum!
JavaRanch » Java Forums » Products » Websphere
Bookmark "SOAP header missing from the message?" Watch "SOAP header missing from the message?" New topic

SOAP header missing from the message?

swarada deshpande

Joined: Aug 17, 2010
Posts: 1
Hello All,

I am new to WID and WPS application development.
Today I came across a situaion where in I need your help to figure out if am I going wrong anywhere.

For testing purpose I have 2 mediation flows and a webservice.
All of these have SOAP1.1 import and export interfaces.

Mediation1 -imports->Mediation2 -imports-> Webservice

In the Mediation1 module implementation after the input terminal "SOAP Header Setter" node is added. Using the "Create" functionality I created one elemnt under SOAPHeader and set it to some default value. Trace node followed by the "SOAP Header Setter" node confirms that header property got added.
<value xsi:type="test:SOAPProperty">
This message is passed to Mediation2 flow using its Web Service Binding SOAP1.1 export.
In Mediation2 flow implementation I have put another trace node immediately followed by the input terminal.
However I do not see the added "SOAPHeader" in the trace file. I can still see SMOHeader, HTTPHeader, BODY etc.And thus when I try to find SOAPHeader -> SOAPProperty I find nothing.

On the import and export terminals I have already checked the setting for propogate webservice header/user context/system context.Is there any other setting I should do for SOAP header to appear in the Mediation2 flow?

Please help me guys, I am stuck at this for quite a long time now.

Thanks in advance for your help.
I agree. Here's the link: http://aspose.com/file-tools
subject: SOAP header missing from the message?
It's not a secret anymore!