File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes Tomcat and the fly likes issue at running port... Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Products » Tomcat
Bookmark "issue at running port..." Watch "issue at running port..." New topic
Author

issue at running port...

Prithviraj Kumar Dasari
Greenhorn

Joined: Oct 16, 2008
Posts: 6
Hi guys,
My latest problem is with Tomcat

I get a following error - java.net.BindException. I learned that machine had another process(none other than tomcat) running at that port.
I have done the following with out any success.
1. I could not get th PID(using command 'netstat -a -o -n' ) for old instance of tomcat, to terminate that process using command'killtask /f /pid XXXX' .
2. I re-installed tomcat, still same results

I do *not* want to run tomcat at other port.

Any body can challenge this issue ?

-Prithvi.
Rene Larsen
Ranch Hand

Joined: Oct 12, 2001
Posts: 1179

Do you have another type of server running - JBoss AS or maybe an Oracle DB ??


Regards, Rene Larsen
Dropbox Invite
vijin das
Ranch Hand

Joined: Jun 07, 2010
Posts: 129

Are running is TOMCAT ???

if yes

Assuming you have no other server already running on port 80, you'll find it convenient to configure Tomcat to run on the default HTTP port (80) instead of the out-of-the-box port of 8080. Making this change lets you use URLs of the form http://localhost/blah instead of http://localhost:8080/blah. Note that you need admin privileges to make this change on Unix/Linux. Also note that some versions of Windows automatically start IIS on port 80. So, if you use XP and want to use port 80 for Tomcat, you may need to disable IIS (see the Administrative Tools section of the Control Panel).

To change the port, edit install_dir/conf/server.xml and change the port attribute of the Connector element from 8080 to 80, yielding a result similar to that below.

<Connector port="80" protocol="HTTP/1.1" ... >

try this... let jboss take 8080 if that is also running parellaly ....

VIJINDAS
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: issue at running port...