There is requirment of upgrade the devlopment and deployment environment in tomcat 6 version in my project, currently we are using tocat 4.1.. and jdk 1.4 in inteljidia 3... version,
but our tool inteljidia 3... is very old , do not know later version of 1.4 and later tocat 4.1( cuurrent inteljidia 9 in the market ). version so i have taken inteljidia 6.0.5 that supprot ...tomcat 6.0.10
but tocat 6 support jre 1.5 so when i configured changing the cuurent jre with exisying compiler of jdk 1.4, giving class version error at run time,
But we know that and sun say that class compiled in jdk 1.4 will run 1.5, is their any problem in class upgradation i know only degradtion problem,
now i have changed all jre jdk both same 1.5 with tomcat 6,with intelj6 is their need to compiled all class with a compiler of 1.5?
still i have compiled the java file deleting the prev... class file
bypassing assertion related problem..
now our jsp is not able to able to make _Jsp.java and corresponding class in application---work directory message come ---"can not find configurationof jsp built in servlet???"
how can i set the path of this for where jsp spec servlet will comile and go in D:\Tomcat\work\Standalone\localhost\webappsname\resources\jsp ......i know that this path auto
built ...when i delets auto comes...?
I can't quite tell from your post what the underlying objective is. Upgrading Tomcat? Upgrading the JRE? Or both? Which versions of each? It's probably a good idea to recompile all classes once you have those versions in place.
You should make those decisions first, and then choose an IDE that supports those. And from personal experience I'd also advise to make sure that at all times you have a build process that is independent of any IDE (maybe using Ant).
the root cause has been detected problem was with IDE actually officially IDE of used version does not support tomcat 6.0.20 they supports t-5 to T-6.0.10.and the problem was also with the setting of source path and classpath.
But tell me one thing which is a big dout in my mind that a class compile in lower version of jdk why gives the class version error at runtime when runs in upper version of jre
i have tested the compile class with jdk1.4 and runs in jre1.5, i have tested out of project in command prompt also by making a class file in jdk1.5 when i runs with 1.6 gives clas version exception,UnsupportedClassVersionError why
If your IDE is IntelliJ 3, yes, it's practically a fossil. I believe that IntelliJ is currently Version 8 or 9. You need to either buy upgrades, or if the budget doesn't allow, switch to one of the free IDEs such as NetBeans or Eclipse. You'll not only gain support for more up-to-date platforms, you'll get a whole boat-load of productivity improvements.
The class version conflict is most often seen when serialization is involved. Sun has always included warnings that the binary encoding formats of serialized objects are not guaranteed to be compatible between different Java versions. Most often I get these problems when I'm doing something like RMI, but there are other cases where version conflicts can occur as well.
Customer surveys are for companies who didn't pay proper attention to begin with.
yes my project class has used serialization in maney palces, whole project is based on transaction oriented in frequent database connectivity application following multithread model. please let me know the cases where version conflict can occur i know only the cause of assertion,enum etc related problem can arise so at the end means
FINALLY for upgradation i will have to recompile the thousand java file of my project with upper version of jdk!!! am i right???
Help me out!
Even with thousands of classes, you're generally better off recompiling all of them so that they all match on version number. Of course, if you have a batch build process such as Maven or Ant, thousands of classes aren't usually a problem. I have projects with hundreds of classes in a single project.