aspose file tools*
The moose likes Android and the fly likes Android newbie's problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Mobile » Android
Bookmark "Android newbie Watch "Android newbie New topic
Author

Android newbie's problem

Goran Markovic
Ranch Hand

Joined: Sep 26, 2008
Posts: 399
Hi, I have just start to develop android, and I just cannot start my Hello World application.
I have followed instructions about android installation, I have changed several Eclipse IDE's, but still, when I press f11 to compile, it 'does' some job int he background, activate my virtual device, but wont to behave just as it should!
Only " Android . . . " is displayed on the screen, which mean that my class isn't 'loaded', somehow.
This is sample class :


And, also main.xml file, which reflect contains xml representation of display window :
main.xml :


then, strings.xml :


AndroidManifest.xml :



and default.properties file :


Just as I said, I did install everything I needed (SDK, ADT plugin, etc...), but it still wont work
I appreciate any help!
Thanks
Ankit Garg
Sheriff

Joined: Aug 03, 2008
Posts: 9293
    
  17

Slobodan at a glance everything looks fine to me. How long did you want for the simulator to boot up?? It can take 2-3 minutes to boot on old machines...


SCJP 6 | SCWCD 5 | Javaranch SCJP FAQ | SCWCD Links
Goran Markovic
Ranch Hand

Joined: Sep 26, 2008
Posts: 399
Hi Ankit.
It takes only a few seconds, and emulator appears, displaying - "ANDROID_" (where underscore continuously blink). Emulator doesn't respond to any button pressing.
Now I am downloading MOTODEV IDE, to try it.
Just as I said, I have downloaded several Eclipse distribution, and permute at any way I could (SDK version, different emulators,etc..) but it wond work
Goran Markovic
Ranch Hand

Joined: Sep 26, 2008
Posts: 399
I have downloaded MOTODEV, but the behavior is the same.. I just do not understand....
David O'Meara
Rancher

Joined: Mar 06, 2001
Posts: 13459

sounds like a problem with the virtual device and not necessarily the application.
Have you tried creating a new one to test the app?
Goran Markovic
Ranch Hand

Joined: Sep 26, 2008
Posts: 399
It breakthrough somehow!
Do not how, but it starts working...I was messing with various type of emulators, and it works (just need to figure out what tpe of emulator I chose, because I tried every )
Thanks for your time and patience...

Regards
James Elsey
Ranch Hand

Joined: Dec 21, 2007
Posts: 228

I've found similar behaviour, sometimes I can load up my application, sometimes I can't

One thing I will suggest, is don't rely on F11 to run it. Its best (in my experience) to right click your project and select "Run as Android", as when I used F11 Eclipse was trying to do something else

Good luck!


Kind Regards, James. OCPJP 1.6 || My SCJP / OCJCP Study Notes
Interested in : SCJP, Google App Engine, Stripes, Android;|| My Bite-Size SCJP Study Blog
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Android newbie's problem