This week's book giveaway is in the Java 8 forum.
We're giving away four copies of Java 8 in Action and have Raoul-Gabriel Urma, Mario Fusco, and Alan Mycroft on-line!
See this thread for details.
The moose likes Ant, Maven and Other Build Tools and the fly likes Possible cause for org.apache.maven.lifecycle.LifecycleExecutionException Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Java 8 in Action this week in the Java 8 forum!
JavaRanch » Java Forums » Engineering » Ant, Maven and Other Build Tools
Bookmark "Possible cause for org.apache.maven.lifecycle.LifecycleExecutionException" Watch "Possible cause for org.apache.maven.lifecycle.LifecycleExecutionException" New topic
Author

Possible cause for org.apache.maven.lifecycle.LifecycleExecutionException

Kumar Raja
Ranch Hand

Joined: Mar 18, 2010
Posts: 516
    
    2


Hello All,

I'm a very new to Maven, (Just gone through couple of documents with no practical exposure) and I downloaded Maven 2.x and after install, I ran mvn.bat out of the box as below



and I got the below error message



Are there any setting changes, I'm expected to do before running this command? Is Maven not ready to use out of box? Please advice.

Regards
KumarRaja

Martijn Verburg
author
Bartender

Joined: Jun 24, 2003
Posts: 3274
    
    5

You are almost certainly being blocked by your proxy server, check the online documentation on how to configure around that. I'd also highly recommend the free "Maven The Definitive Guide" PDF by Sonatype


Cheers, Martijn - Blog,
Twitter, PCGen, Ikasan, My The Well-Grounded Java Developer book!,
My start-up.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Possible cause for org.apache.maven.lifecycle.LifecycleExecutionException
 
Similar Threads
Maven exception
Not Getting Started with Maven - Archtype plugin Not found
Maven archtype plugin doesn't exist error
The plugin 'org.apache.maven.plugins:maven-eclispe-plugin' does not exist or no valid version could
maven-archetype-plugin: does not exist ?