aspose file tools*
The moose likes Struts and the fly likes Bizarre Problem related to Struts-config.xml : Improper format Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "Bizarre Problem related to Struts-config.xml : Improper format " Watch "Bizarre Problem related to Struts-config.xml : Improper format " New topic
Author

Bizarre Problem related to Struts-config.xml : Improper format

shobit srivastava
Greenhorn

Joined: Nov 11, 2006
Posts: 3
Hello Every one !

We struck up in a bizarre struts related problem. To begin with , We are migrating a framwork (which uses struts as underlying framework) .While doing the migration impact analysis , we found that we have to migrate from struts 1.0 to struts 1.2 . we did take necessary steps to perform the migration For example - specifying message resource in struts.config instead of web.xml (Please note that Previously struts 1.0 mandates that message resources be specfied in web.xml. This functionality was deprecated in struts1.1 and removed in struts1.2).

Here is code snippet of struts-config.xml , which we are using in our application



Interestingly the above struts-config was working on my colleague's work station even though we did not conform with struts 1.2 dtd pattern . However when we posted the code in repository & again retook the code from repository on different work station & tried to run it . We ended up getting following error :



I realized the dtd issue & fixed up by harding coding the path of DTD in following manner :




But still the same error is resurfacing . Any help would be highly appreciated !! I am running out of any further thoughts after seeing bizarre behavior of struts-config (i.e. one work station it is working without conforming to struts 1.2 dtd how ever on other system it is not working even though we are referring to correct dtd )

Regards
Shobit
 
It is sorta covered in the JavaRanch Style Guide.
 
subject: Bizarre Problem related to Struts-config.xml : Improper format