This week's book giveaways are in the Java EE and JavaScript forums.
We're giving away four copies each of The Java EE 7 Tutorial Volume 1 or Volume 2(winners choice) and jQuery UI in Action and have the authors on-line!
See this thread and this one for details.
The moose likes Struts and the fly likes struts 2 application not running Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "struts 2 application not running " Watch "struts 2 application not running " New topic
Author

struts 2 application not running

Manish Sahni
Ranch Hand

Joined: Sep 09, 2009
Posts: 41

Hi, i am a beginner in struts2 .
When i was trying to make a simple application,their was an error stating that the "module has not been deployed "
I am using netbeans 6.8 IDE and my configuration files are:-
struts.xml


web.xml:-


The log file states:-
the Jar files i have imported are:

freemarker 2.3.8
ognl 2.6.11
struts2-core-2.0.14
xwork-2.0.7
commons-beanutils
commons-collection
commons-digester
commons-logging
commons-logging-api
commons-validator

Please let me know the root cause and what needs to be done?

David Newton
Author
Rancher

Joined: Sep 29, 2008
Posts: 12617

The root cause is that it can't find the action class, just like the error says.

You'll also need commons-io and commons-fileupload.
 
Consider Paul's rocket mass heater.
 
subject: struts 2 application not running