• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Help, struts aplication at Tomcat very slow

 
Rohit Mehta
Ranch Hand
Posts: 79
Chrome Eclipse IDE Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
hi all
details of my application:
Tomcat 5.0/struts, using two third party softwares, including one native call
problem is application going slow at server , when i call third oarty software, it shows cpu usage 95% & it becomes very slow ,
same code was fine till some time ago, locally working fine still
may anybody help me , i m really in trouble, no solution seems

thnx
rohit
 
Ernest Friedman-Hill
author and iconoclast
Marshal
Pie
Posts: 24208
35
Chrome Eclipse IDE Mac OS X
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Rohit,

Welcome to JavaRanch!

Please post just one copy of a question to one forum. Doing otherwise just wastes people's time -- someone may put a lot of work into answering one copy of your question, when another has already been answered satisfactorily. I deleted the three other copies of this question for you.

As to your question, I'll answer with some more questions: 1) what does the "third party software" do? Is there some reason why it would now take longer? 2) What has changed about your machine since the code worked? Could it somehow effect the performance of the application?
 
Rohit Mehta
Ranch Hand
Posts: 79
Chrome Eclipse IDE Spring
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi Earnest
thanx for ur attention, & sorry for that, actually i posted it at diff places because i didnt find a place for Tomcat.

it is a shipment site, a shipper login & put destination /origin zip, weight, & other details, after that there is a DLL file called in which 3rd Party software is called which produce rates according to information.
that software has client at one machine & server at another
Dll is in VC++
most of the problem started after the 3rd party software update, we r also loooking that
at local site is fine, but tomcat specially slows at page wher dll is called
tomcat process shows cpu usage 95%
nothing at machine change, but i was trying to add some new module
if u hav touch with struts , plz tell how can i better see at code side

plz look at it, i would b very thankful
thnx & regards
rohit
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic