This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes Java in General and the fly likes Uninstalling Java Not Working Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Java » Java in General
Bookmark "Uninstalling Java Not Working" Watch "Uninstalling Java Not Working" New topic
Author

Uninstalling Java Not Working

Jon Smithson
Greenhorn

Joined: Aug 29, 2010
Posts: 3
Hey everyone!

I'm a bit new to the forums, so please humor me.

Recently, I was trying to get started with Java3D, but no matter what I did, it threw an UnsatisfiedLinkError. In an attempt to fix this, I uninstalled my JRE, SDK, and the 3D api. Everything was going fine and dandy, until I reinstalled the SDK, the JRE, and the 3D api and almost everything stopped working! I could compile and run programs from the command line, but online applets and games, along with Eclipse, my favorite IDE, have stopped working.

At this point, I wasn't not panicking. I mean, all I need to do is uninstall everything and start fresh, right? I figured that installing the SDK before the JRE had caused the problem. So I uninstalled the 3D api and the SDK (again!), but for some reason, as I uninstalled the JRE, it gave me this error:

Error 1723. There is a problem with this Windows Installer package. A DLL required for this install to complete could not be run. Contact your support personnel or package vendor.

I've tried everything to fix this problem, and I'm out of ideas. Hopefully some of you wise code ranchers can help me with my problem!

Additional info:
  • I did delete a bunch of stuff from the Java folders after getting this error in an attempt to manually uninstall it. I'm currently copying these files back from another machine.
  • On "Add or Remove Programs," this is listed as "Java (TM) 6 Update 21". I tried the 64 bit version, but applets and Web Launch programs still don't work.
  • I'm running Windows 7 64 bit.
  • Jan Cumps
    Bartender

    Joined: Dec 20, 2006
    Posts: 2491
        
        8

    Welcome to JavaRanch.
    Please check your private messages for an administrative matter.


    OCUP UML fundamental and ITIL foundation
    youtube channel
    Jon Smithson
    Greenhorn

    Joined: Aug 29, 2010
    Posts: 3
    Ok, thank you. I took care of that.
    Jesper de Jong
    Java Cowboy
    Saloon Keeper

    Joined: Aug 16, 2005
    Posts: 14074
        
      16

    Welcome to JavaRanch.

    If you Google for "java error 1723", you'll find that you're not the first one who gets this error...

    UnsatisfiedLinkError means that Java can't find a native library (a DLL, if you're running Windows) that it needs. Re-installing Java and Java3D is most likely not going to solve that problem. You just need to make sure that the native libraries that are necessary for Java3D can be found. You can do that by specifying the system property java.library.path on the command line when you start your program. It must point to the directory that contains the necessary DLLs.

    java -Djava.library.path=C:\some\directory com.mypackage.MyProgram


    Java Beginners FAQ - JavaRanch SCJP FAQ - The Java Tutorial - Java SE 7 API documentation
    Scala Notes - My blog about Scala
    Jon Smithson
    Greenhorn

    Joined: Aug 29, 2010
    Posts: 3
    Thank you for the help. I'll keep looking for the solution that works.
     
    Don't get me started about those stupid light bulbs.
     
    subject: Uninstalling Java Not Working
     
    Similar Threads
    Eclipse Windows 7 (64) bit Does'nt Start.
    Java\bin PATH setup
    Java Installation/Uninstallation Help
    Error 1723 when trying to uninstall jdk java 1.6 update 24 and unable to install again.
    error involving 64-bit windows 7, can't figure it out