• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

error in transform from database-to->xml-to->xhtml:The XML page cannot be displayed

 
Leonidas Savvides
Ranch Hand
Posts: 403
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I get this error in transform from database-to->xml-to->xhtml although if view SOURCE IS RIGHT/CORRECT...
where is error?

VIEW SOURCE ON ABOVE ERROR PAGE:



 
Jeanne Boyarsky
author & internet detective
Marshal
Posts: 34207
341
Eclipse IDE Java VI Editor
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I'm really not going to scroll all the way to the right to see that--have you considered running it through a tidy to make it legible?
 
Leonidas Savvides
Ranch Hand
Posts: 403
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
what is "tidy"?
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Literally, "clean". Like HTMLTidy.
 
Leonidas Savvides
Ranch Hand
Posts: 403
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
if you mean the SOURCE, I put it in dreamweaver and appear reasonable... why then the xml error?
 
David Newton
Author
Rancher
Posts: 12617
IntelliJ IDE Ruby
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I mean if you expect us to look at the generated source, clean it up before posting--do you see how it's all on one line and if we want to look at it we need to scroll right a half-dozen screens.
 
Leonidas Savvides
Ranch Hand
Posts: 403
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
generate code(CODE MODE) give full correct VIEW LAYOUT, you do not need it, is correct... why the error, why this page do NOT appear at start?
 
Leonidas Savvides
Ranch Hand
Posts: 403
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I mean appeared XML Error in browser, but if you View-source and cut/paste code in dreamweaver, this gives in DESIGN MODE propel/correct/expected design(html table with correct data)... any idea why the XML error?
 
William Brogden
Author and all-around good cowpoke
Rancher
Posts: 13058
6
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator


That looks like a clue to me. Somewhere in that text the HTML interpreter hits what it thinks is a parameter entity.

Bill
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic