aspose file tools*
The moose likes IDEs, Version Control and other tools and the fly likes GVIM on Windows XP problem Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "GVIM on Windows XP problem" Watch "GVIM on Windows XP problem" New topic
Author

GVIM on Windows XP problem

Carey Brown
Ranch Hand

Joined: Nov 19, 2001
Posts: 244

I've been using gvim version 7.1 on my PC at work for a long time with no problems. However, somewhere between Friday and Monday it will no longer display the menu or toolbar. I'm assuming that either I fat-fingered something Friday afternoon or a file got corrupted or corporate "updated" something on my machine.

Here's what I've tried:

  • Uninstalling and installing the new 7.3 version. This includes deleting my rc files.

  • Running :set guioptions+=m

Has anyone else run into this?


Sent from my IBM 360 mainframe
Christophe Verré
Sheriff

Joined: Nov 24, 2005
Posts: 14688
    
  16

I've never seen this, so I'm afraid I won 't be of any help.

1. What is the current value of guioptions ? (:set guioptions).
2. You do have menu.vim in the runtime folder, don't you ?


[My Blog]
All roads lead to JavaRanch
Carey Brown
Ranch Hand

Joined: Nov 19, 2001
Posts: 244

GOT IT!
Environment variable VIMRUNTIME somehow got deleted.

Thanks,
Carey
Christophe Verré
Sheriff

Joined: Nov 24, 2005
Posts: 14688
    
  16

Great you solved it
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: GVIM on Windows XP problem