This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes JBoss/WildFly and the fly likes Application running in my jboss but when i put it in the client JBoss it showing error Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "Application running in my jboss but when i put it in the client JBoss it showing error" Watch "Application running in my jboss but when i put it in the client JBoss it showing error" New topic
Author

Application running in my jboss but when i put it in the client JBoss it showing error

riaz mahsha mohamed
Greenhorn

Joined: Aug 18, 2010
Posts: 16
hi friends i have developed an application connecting with web services, the app which we have developed is working properly but when i put war file and when i deploy in client Jboss it shows ERROR ('');

ERROR [STDERR] AxisFault

faultCode : http://schemas.xmlsoap.org/soap/envelope/Server.userException
faultSubCode :
faultString : java.net.ConnectException : Connectin refuced : connect
faultActor :
faultNode :
faultDetail :
http://xml.apache.org/axis/stackTrace:java.net.ConnectException: Connection refused : connect
Greg Charles
Sheriff

Joined: Oct 01, 2001
Posts: 2840
    
  11

That's not a lot to go on, since there are many thing that could cause a ConnectException: bad network, no network, firewall, bad address, routing issue, etc. However, it does seem that the client connects to the server, but then is rejected. Could it be you're not providing the credentials (probably a user name and password) necessary to access the service?
 
 
subject: Application running in my jboss but when i put it in the client JBoss it showing error
 
Similar Threads
UnknownhostException
WS Security with Axis
JBoss initialcontext problem
Configuration of an application in JBoss Xml File
HTTP 404 error