aspose file tools*
The moose likes Struts and the fly likes After upgrading from 2.0.x to 2.2.x, static content no longer loads Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of The Java EE 7 Tutorial Volume 1 or Volume 2 this week in the Java EE forum
or jQuery UI in Action in the JavaScript forum!
JavaRanch » Java Forums » Frameworks » Struts
Bookmark "After upgrading from 2.0.x to 2.2.x, static content no longer loads" Watch "After upgrading from 2.0.x to 2.2.x, static content no longer loads" New topic
Author

After upgrading from 2.0.x to 2.2.x, static content no longer loads

Eric Nielsen
Ranch Hand

Joined: Dec 14, 2004
Posts: 194
I recently upgraded from Struts 2.0.x + SmartURLs to Struts 2.2.1 + Convention plugin. However after upgrading all my static content is no longer being served. I read all the release notes along the way that I could find and nothing suggests that my old approach should have stopped working. I'm assuming my old system worked because of some (probably wrong) usage I was making with SmartURLs since that's the only change that touched the filters. Can anyone point out what else I need to change/tweak to get static content behaving again?

I'm using Maven as the build system.
static content is at


Here are my filters from web.xml


Here's the root node and contents of the struts.xml:
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: After upgrading from 2.0.x to 2.2.x, static content no longer loads