File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes IDEs, Version Control and other tools and the fly likes Facets in Eclipse? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "Facets in Eclipse?" Watch "Facets in Eclipse?" New topic
Author

Facets in Eclipse?

Joseph Sweet
Ranch Hand

Joined: Jan 29, 2005
Posts: 327
I am using the latest Eclipse Java EE IDE for Web Developers, latest Maven and the M2Eclipse plugin.

I am trying to follow the following tutorial:

Creating Dynamic Web Project using Maven in Eclipse

First time I tried, on step 3 (setting facets) I got the window shown in image "facets 1".
That time the project worked (i was able to run it in Eclipse)

Then I tried the same tutorial again (under a different name, i.e. different project).
On step 3 (setting facets) I got the window shown in image "facets 2". I clicked to convert but did not get immediately the list of facets. I tried to restart Eclipse and then I was able to get the list of facets. Weird?
But something even weirder, this time I got the window shown in image "facets 3". As you can see, the list of facets is longer. Why?
Also, this time the project did not run in Eclipse: I got error 404 "The requested resource is not available." Why?

What is wrong with Eclipse? Is it a bug?
And why did the project not run on the second time?

Thank you.

We must know, we will know. -- David Hilbert
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Facets in Eclipse?