Two Laptop Bag*
The moose likes JBoss/WildFly and the fly likes Session not bound? Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "Session not bound?" Watch "Session not bound?" New topic
Author

Session not bound?

Maja Gralewska
Ranch Hand

Joined: Sep 26, 2008
Posts: 92
Heya,

Iv got this weird problem with my deploy, normally the .jar is about 12KB, code has not been removed only added. The size of the .jar now is about 9KB

The basic structure of the program is Project->Packages-> exClientController.java, exModel.java, exSessionBean.java, ExPersistance.java, ex.java

The Session & SessionHome for the sessionBean are generated by the xdoclet and put in a separate package called interfaces.

The complete process consists of 4 steps as follows:

1) xdoclet (creates the sessions)
2) refresh & clean
3) package (build)
4) deploy (signer)

I get multiple errors of the following(for different sessions) when I run the xdoclet:

[org.jboss.ejb.plugins.local.BaseLocalProxyFactory] TariffedInvoiceLineExStoreSession cannot be Bound, doesn't have local and local home interfaces...

The session does exist and is created successfully.

Here is the xdoclet:




Any ideas on what the problem could be? The code does not contain any errors either.

I have tried stopping jboss & restarting as well as the server & eclipse.

Thanks for your help.


Potrzeba jest matka wynalazków
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Session not bound?
 
Similar Threads
SAXParseException: The content of element type "enterprise-beans" is incomplete, it m
EntityFacade and Xdoclet
Using ANT and XDoclet
package javax.ejb does not exist
SAXParseException: The content of element type "enterprise-beans" is incomplete, it m