• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Can't render custom facelet component in IceFaces

 
Carlos Conti
Ranch Hand
Posts: 131
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi greenhorns,

I have been looking some tutorials on this issue but am not getting through.... can anyone please help??

I am trying to set up a custom JSF/IceFaces facelets component, and although following the steps in the official IceFaces guide (which must say is too basic and lacks many details) I don't get to render the tag, or only get thrown exceptions on non found facelet definitions.

Here are the relevant parts of my sources:

I) In /WEB-INF/ I define the file custom.taglib.xml:



II) In /WEB-INF/web.xml I point to the taglib file like:



III) In the folder
comunes/taglib/
I define the jspx file that contains the component specificacion:




IV) Finally I call the custom tag from another facelet file like :



The last error I got looked like this...

com.sun.facelets.tag.TagException: /entradas/SeccionDatosEntrada.jspx @69,44 <cst:selectPlantilla> Facelet Not Found: jndi:/comunes/taglib/selectPlantilla.jspx


I work with NetBeans6.8. My main problem is that the facelet is either not rendered or not found. Additionally if anyone could point me on how to make NB recognize the tags would be fantastic. However that's not the main problem. I believe this last issue could be solved defining a normal tld file right?, I have read somewhere that IDE's prefer tld files for tagname resolution.

Thanks for your insights.

Carlos.
 
Carlos Conti
Ranch Hand
Posts: 131
  • Likes 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
SOLVED! can't believe it...

the solution was to type '../' at the beginning of the <source> path in the customs.taglib.xml file. Amazing. Struggling with this for hours...
Why aren't such things specified in the documentation? Depending on the context you must play around with different path setting rules... can't they come together for the sake of simplicity??

Hope nobody lost as long as I did with it!
 
Marek Bedkowski
Greenhorn
Posts: 1
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Carlos Conti wrote:SOLVED! can't believe it...

the solution was to type '../' at the beginning of the <source> path in the customs.taglib.xml file. Amazing. Struggling with this for hours...
Why aren't such things specified in the documentation? Depending on the context you must play around with different path setting rules... can't they come together for the sake of simplicity??

Hope nobody lost as long as I did with it!


Thanks Carlos... you saved me couple of hours...
 
Carlos Conti
Ranch Hand
Posts: 131
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I have been advised many times in this forum... so I am happy that from time to time I can pay a bit of it back...

Regards,
Carlos.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic