This week's book giveaway is in the Clojure forum.
We're giving away four copies of Clojure in Action and have Amit Rathore and Francis Avila on-line!
See this thread for details.
Win a copy of Clojure in Action this week in the Clojure forum!
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Context injection failed on service access

 
Kumar Raja
Ranch Hand
Posts: 547
2
Hibernate Java Spring
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hello All,

I have my SEI designed as below



My service is deployed in GlassFish v3.0 and on service access, I'm receiving the below error message indicating that dependency injection failed.



Any advice on why I'm seeing this and what should be done to avoid this.
 
Kumar Raja
Ranch Hand
Posts: 547
2
Hibernate Java Spring
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hmm, after referring to Ivan's notes I realized that I need to inject WebServiceContext instead of MessageContext, which I retried again but still receiving the injection failure exception as mentioned before. The surprise part is, when I tried the example given by Ivan in his material, it worked great. But in my version, I started accessing the WebServiceContext instead of mere declaration using @Resource.



My SOAP Request and response are as below

Request


Response
 
Kumar Raja
Ranch Hand
Posts: 547
2
Hibernate Java Spring
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Can somebody advice me ,why I'm getting injection failure.
 
Ivan Krizsan
Ranch Hand
Posts: 2198
1
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Hi!
Start from the example in my study notes that work and modify it step-by-step until your problem appears.
Test after each step. This way you can determine what caused injection of the context to fail.
Best wishes!
 
Kumar Raja
Ranch Hand
Posts: 547
2
Hibernate Java Spring
  • 0
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Well I got this exception fixed. I don't know how it got fixed, but after couple of reattempts, it ran fine.
 
I agree. Here's the link: http://aspose.com/file-tools
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic