File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes IDEs, Version Control and other tools and the fly likes StandardEmitterMBean Compile Error in Eclipse Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "StandardEmitterMBean Compile Error in Eclipse" Watch "StandardEmitterMBean Compile Error in Eclipse" New topic
Author

StandardEmitterMBean Compile Error in Eclipse

Bob Harvey
Greenhorn

Joined: Oct 23, 2010
Posts: 1
Hello - I'm getting a compile error in Eclipse for the following:

The project was not built since its build path is incomplete. Cannot find the class file for javax.management.StandardEmitterMBean. Fix the build path then try building this project IOSv1DataConnector Unknown Java Problem
The type javax.management.StandardEmitterMBean cannot be resolved. It is indirectly referenced from required .class files DataProcessor.java /mypackage/dataprocessor line 510 Java Problem


I've tried the site jarfinder to no avail.

Thanks
Rob Spoor
Sheriff

Joined: Oct 27, 2005
Posts: 19656
    
  18

Welcome to the Ranch, Bob!

Which version of Java are you using? That class is available since Java 6 (a.k.a. 1.6, as can be seen in the Javadoc). If you're using an older version then the class simply doesn't exist yet.


SCJP 1.4 - SCJP 6 - SCWCD 5 - OCEEJBD 6
How To Ask Questions How To Answer Questions
Campbell Ritchie
Sheriff

Joined: Oct 13, 2005
Posts: 38087
    
  22
Assuming you are using Java 6, as Rob suggests, you can set Eclipse to use that (or any other) version. If that is the problem, it might be better to discuss that on our IDEs forum, so I shall move this thread.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: StandardEmitterMBean Compile Error in Eclipse
 
Similar Threads
Eclipse is running in a JRE, but a JDK is required
Eclipse : A cycle was detected in the build path of project
The compilation unit is not on the build path..
JVM why not finding libs in other project classpath
eclipse