This week's giveaway is in the Android forum.
We're giving away four copies of Android Security Essentials Live Lessons and have Godfrey Nolan on-line!
See this thread for details.
The moose likes JSF and the fly likes richfaces components are not getting displayed on jsf 2.0 tomcat 6.0 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Android Security Essentials Live Lessons this week in the Android forum!
JavaRanch » Java Forums » Java » JSF
Bookmark "richfaces components are not getting displayed on jsf 2.0 tomcat 6.0" Watch "richfaces components are not getting displayed on jsf 2.0 tomcat 6.0" New topic
Author

richfaces components are not getting displayed on jsf 2.0 tomcat 6.0

puneetgoyal king
Greenhorn

Joined: Aug 29, 2010
Posts: 7
i get this error message on my web browser and richfaces components are not getting displayed..
i am using jsf 2.0 mojarra implementation, tomcat 6.0 and richfaces 4.0


* Warning: This page calls for XML namespace http://richfaces.org/rich declared with prefix rich but no taglibrary exists for that namespace.
Mital Pritmani
Greenhorn

Joined: Jan 20, 2010
Posts: 9

I was getting same error for .xhtml pages. When I changed it to .jsf (in pattern and also in welcome file list), the warning got disappeared and all the richfaces components started working well.
 
 
subject: richfaces components are not getting displayed on jsf 2.0 tomcat 6.0
 
Similar Threads
JSF 2.0 and Richfaces
problem when using a4j:commandButton and a4j:commandLink
Where is the rich:modalPanel in component JSF2.0?
It seems the code JSF 2.0 controls aren't updating backing beans
Richfaces 4.0 message