aspose file tools*
The moose likes JSP and the fly likes problem while importing output of the URL in JSP using JSTL Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Java » JSP
Bookmark "problem while importing output of the URL in JSP using JSTL" Watch "problem while importing output of the URL in JSP using JSTL" New topic
Author

problem while importing output of the URL in JSP using JSTL

Manish Hatwalne
Ranch Hand

Joined: Sep 22, 2001
Posts: 2578

I have not used JSTL before, so please excuse me if it sounds rather rudimentary.

I am trying to import output of a script in my JSP page, I want to store it in a variable, but for some weird reason I am not able to store it in a variable. However, when I directly import it works fine. Any idea where I should look for the problem?



Any pointers would be highly appreciated!

rgds,
- Manish

Christophe Verré
Sheriff

Joined: Nov 24, 2005
Posts: 14687
    
  16

Is your container properly configured to use EL ? Check this FAQ.


[My Blog]
All roads lead to JavaRanch
Manish Hatwalne
Ranch Hand

Joined: Sep 22, 2001
Posts: 2578

Christophe Verré wrote:Is your container properly configured to use EL ? Check this FAQ.


I checked. I am using JSTL 1.1 and it support "var" attribute, am clueless why it is not working!
What other configuration could be wrong?

TIA,
- Manish
Christophe Verré
Sheriff

Joined: Nov 24, 2005
Posts: 14687
    
  16

Manish Hatwalne wrote:I checked. I am using JSTL 1.1 and it support "var" attribute, am clueless why it is not working!
What other configuration could be wrong?
- Manish


You should check if you can use EL. Did you check that your web.xml is correctly configured ?Try the following :

If the URI is not displayed, then EL is not configured properly. You'd have to check your web.xml again.

Manish Hatwalne
Ranch Hand

Joined: Sep 22, 2001
Posts: 2578

Christophe Verré wrote:
Manish Hatwalne wrote:
Christophe Verré wrote:I checked. I am using JSTL 1.1 and it support "var" attribute, am clueless why it is not working!
What other configuration could be wrong?
- Manish


You should check if you can use EL. Did you check that your web.xml is correctly configured ?Try the following :

If the URI is not displayed, then EL is not configured properly. You'd have to check your web.xml again.


I cannot see this I get it as it is and not the value. But I do see output when I simply use -
<c:import url="http://mydomain.tld/doSomething.do"/>

It is only when I try to put in a variable, I don't get the output stored in that variable.
As for configuration, I am using Alfresco 3.3G, so entire web.xml is as it is - we haven't touched it. Any idea how can I get this working?

TIA,
- Manish




 
Don't get me started about those stupid light bulbs.
 
subject: problem while importing output of the URL in JSP using JSTL