aspose file tools*
The moose likes HTML, CSS and JavaScript and the fly likes how to disable autocomplete for password Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » HTML, CSS and JavaScript
Bookmark "how to disable autocomplete for password" Watch "how to disable autocomplete for password" New topic
Author

how to disable autocomplete for password

zheng li
Ranch Hand

Joined: Jun 16, 2009
Posts: 56
I don't know if here is the right place to ask this question.
if it is not, i apologize.

I know how to disable it by using javascript or tools->internet options.
the question is
if i deploy my application on local computer(window 2K), password can be remembered, and whenever i input username, password textbox will be filled automatically.
but when i deploy it on company's server(solaris), password can never be remembered.

is there any configuration about remembering password or not in tomcat or apache?
Andrew Monkhouse
author and jackaroo
Marshal Commander

Joined: Mar 28, 2003
Posts: 11484
    
  94

Most browsers will not allow autocomplete for https sessions, so one option is to have http for your development box, and https for your production servers.

Another option is to specify autocomplete="off" in the input field for the password - this is a non-standard extension that seems to be accepted by IE and Mozilla browsers.


The Sun Certified Java Developer Exam with J2SE 5: paper version from Amazon, PDF from Apress, Online reference: Books 24x7 Personal blog
zheng li
Ranch Hand

Joined: Jun 16, 2009
Posts: 56
sorry, my quesion was not clear enough.

i deployed the same application which has a login page on the server and my local computer.
if i access http://localhost:8080/app/login.jsp, when i input username, password will be auto completed which means browser remembers the password.
but if i access
http://server/app/login.jsp, browser don't remember password.
both server and local are http.

there is only tomcat on my local computer, but on the server, there are apache and tomcat.
Eric Pascarello
author
Rancher

Joined: Nov 08, 2001
Posts: 15376
    
    6
Sounds like different browser settings for different internet/intranet regions.

Remembering password has nothing to do with the server, it is all the work of the browser.

Eric
Eric Pascarello
author
Rancher

Joined: Nov 08, 2001
Posts: 15376
    
    6
Also read this: https://developer.mozilla.org/en/how_to_turn_off_form_autocompletion

Eric
zheng li
Ranch Hand

Joined: Jun 16, 2009
Posts: 56
different browser settings for different internet/intranet regions?

how to do it?
 
jQuery in Action, 2nd edition
 
subject: how to disable autocomplete for password