• Post Reply
  • Bookmark Topic Watch Topic
  • New Topic

Cannot see web project option in eclipse 3.6

 
Reshma Rangarajan
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
I am not very familiar with this area, so appreciate any help on this.

Installed eclipse 3.6.1, JDK1.4 and Weblogic 8.1. Then found out that eclipse 3.6.1 is only for JDk1.5 and weblogic 8.1
is for JDK1.4. So I reinstalled eclipse 3.6 which is compatible with JDK1.4. Now when i try to click on the eclipse exe icon to fireup
eclipse it was giving the error like 'No JRE or JDK found ....'. So i went back and made sure that my PATH and JAVA_Home variables are pointing to the right dir. Now it fires up. I want to test a simple jsp, but i cannot see a web project option under the File -> New -> Other menu. Any idea?

- Thanks, Reshma
 
Somnath Mallick
Ranch Hand
Posts: 482
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Go to New-->Other-->Web-->Dynamic Web Project/Static Web Project.
 
Reshma Rangarajan
Greenhorn
Posts: 8
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
My eclipse version is 3.6 and i cannot find the Dynamic web project option in 'Other'. However, i did see that option when i installed eclipse 3.6.1 . Now the problem is that i have to use weblogic 8.1 which works with java 1.4 but eclipse 3.6.1 requires java 1.5 or higher. So i tried to install the WTP plugin into my eclipse 3.6. But it stops with errors saying that some prerequisites are not met.
 
Peter Johnson
author
Bartender
Posts: 5852
7
Android Eclipse IDE Ubuntu
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Which variant of Eclipse did you install? You need the one labelled "Eclipse for Java EE Developers," that one lets you create web projects.

By the way, you can use Eclipse 3.6.1 and still built JDK 1.4 apps. You will need a 1.5 JDK to run Eclipse, but once running you can either add a 1.4 JDK to the list of JDKs and use that for your project, or set the source and target levels for your projects to be 1.4.
 
Somnath Mallick
Ranch Hand
Posts: 482
  • Mark post as helpful
  • send pies
  • Quote
  • Report post to moderator
Prerequisites are not met was something even i had trouble with. And i had version which Peter mentioned. All i did was to install one feature at a time to find out which aspect of the WTP plugin was causing the trouble. I have left them out. 3.6 would mean Helios, right? Just make sure which one you downloaded.
 
  • Post Reply
  • Bookmark Topic Watch Topic
  • New Topic