File APIs for Java Developers
Manipulate DOC, XLS, PPT, PDF and many others from your application.
http://aspose.com/file-tools
The moose likes JBoss/WildFly and the fly likes JBoss not running on macOSx 10.6.4 Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Products » JBoss/WildFly
Bookmark "JBoss not running on macOSx 10.6.4 " Watch "JBoss not running on macOSx 10.6.4 " New topic
Author

JBoss not running on macOSx 10.6.4

sagar giri
Greenhorn

Joined: Nov 08, 2010
Posts: 5
Hi,
I am a newbie with mac. I am trying to start the JBoss AS and this is the message i get when i type "./run.sh" in the terminal.
=========================================================================

JBossOSGi Bootstrap Environment

OSGI_HOME: /Users/sgiri/Applications/JBoss/runtime

JAVA: java

JAVA_OPTS: -Dprogram.name=run.sh -Dosgi.home=/Users/sgiri/Applications/JBoss/runtime -Xms128m -Xmx512m -XX:MaxPermSize=256m -Dsun.rmi.dgc.client.gcInterval=3600000 -Dsun.rmi.dgc.server.gcInterval=3600000 -Djboss.vfs.leakDebugging=true

=========================================================================

15:07:46,163 INFO [FrameworkState] JBossOSGi Framework Core - 1.0.0.Alpha8
15:07:46,216 INFO [FrameworkEventsPluginImpl] Bundle STARTED: system.bundle:0.0.0
15:07:46,231 WARN [vfs] VFS was unable to set the URLStreamHandlerFactory. This will have unpredictable results
15:07:46,306 INFO [FrameworkEventsPluginImpl] Bundle INSTALLED: osgi.cmpn:4.2.0.200908310645
15:07:46,318 INFO [FrameworkEventsPluginImpl] Bundle INSTALLED: org.apache.felix.log:1.0.0
15:07:46,334 INFO [FrameworkEventsPluginImpl] Bundle INSTALLED: jboss-osgi-common:1.0.6
15:07:46,340 INFO [FrameworkEventsPluginImpl] Bundle INSTALLED: jboss-osgi-hotdeploy:1.0.8
15:07:46,341 INFO [StartLevelPluginImpl] Starting bundles for start level 1
15:07:46,491 INFO [FrameworkEventsPluginImpl] Bundle STARTED: org.apache.felix.log:1.0.0
15:07:46,623 INFO [FrameworkEventsPluginImpl] Bundle STARTED: jboss-osgi-common:1.0.6
15:07:46,678 INFO [DeploymentScannerImpl] Start DeploymentScanner: [scandir=.../server/default/deploy,interval=2000ms]
15:07:46,681 INFO [FrameworkEventsPluginImpl] Bundle STARTED: jboss-osgi-hotdeploy:1.0.8
15:07:46,683 INFO [FrameworkEventsPluginImpl] Framwork STARTED
15:07:46,684 INFO [OSGiBootstrapBean] JBossOSGi Runtime booted in 0.521sec
15:07:46,747 INFO [FrameworkEventsPluginImpl] Bundle INSTALLED: jboss-osgi-common-core:2.2.17.SP1
15:07:46,756 INFO [FrameworkEventsPluginImpl] Bundle INSTALLED: jboss-osgi-jmx:1.0.8
15:07:46,783 INFO [FrameworkEventsPluginImpl] Bundle INSTALLED: jboss-osgi-jndi:1.0.4
15:07:46,793 INFO [FrameworkEventsPluginImpl] Bundle INSTALLED: org.apache.aries.jmx:0.1.0.incubating
15:07:46,808 INFO [FrameworkEventsPluginImpl] Bundle INSTALLED: org.apache.aries.util:0.1.0.incubating
15:07:46,813 INFO [FrameworkEventsPluginImpl] Bundle INSTALLED: org.apache.felix.configadmin:1.2.4
15:07:46,816 INFO [FrameworkEventsPluginImpl] Bundle INSTALLED: org.apache.felix.eventadmin:1.2.2
15:07:47,163 INFO [FrameworkEventsPluginImpl] Bundle STARTED: jboss-osgi-jmx:1.0.8
15:07:47,187 INFO [JNPServer] JNDI started: JNP=localhost:1099, RMI=localhost:1098
15:07:47,190 INFO [FrameworkEventsPluginImpl] Bundle STARTED: jboss-osgi-jndi:1.0.4
15:07:47,192 INFO [FrameworkEventsPluginImpl] Bundle STARTED: jboss-osgi-common-core:2.2.17.SP1
15:07:47,242 INFO [FrameworkEventsPluginImpl] Bundle STARTED: org.apache.felix.configadmin:1.2.4
15:07:47,249 INFO [FrameworkEventsPluginImpl] Bundle STARTED: org.apache.aries.util:0.1.0.incubating
15:07:47,257 INFO [jmx] Starting JMX OSGi agent
15:07:47,275 INFO [jmx] Registering MBean with ObjectName [osgi.compendium:service=cm,version=1.3] for service with service.id [14]
15:07:47,292 INFO [FrameworkEventsPluginImpl] Bundle STARTED: org.apache.aries.jmx:0.1.0.incubating
15:07:47,332 INFO [jmx] Registering org.osgi.jmx.framework.ServiceStateMBean to MBeanServer com.sun.jmx.mbeanserver.JmxMBeanServer@259a8416 with name osgi.core:type=serviceState,version=1.5
15:07:47,332 INFO [jmx] Registering org.osgi.jmx.framework.PackageStateMBean to MBeanServer com.sun.jmx.mbeanserver.JmxMBeanServer@259a8416 with name osgi.core:type=packageState,version=1.5
15:07:47,332 INFO [jmx] Registering org.osgi.jmx.framework.FrameworkMBean to MBeanServer com.sun.jmx.mbeanserver.JmxMBeanServer@259a8416 with name osgi.core:type=framework,version=1.5
15:07:47,345 INFO [jmx] Registering org.osgi.jmx.framework.BundleStateMBean to MBeanServer com.sun.jmx.mbeanserver.JmxMBeanServer@259a8416 with name osgi.core:type=bundleState,version=1.5
15:07:47,350 INFO [jmx] Registering org.osgi.jmx.service.cm.ConfigurationAdminMBean to MBeanServer com.sun.jmx.mbeanserver.JmxMBeanServer@259a8416 with name osgi.compendium:service=cm,version=1.3
15:07:47,356 INFO [FrameworkEventsPluginImpl] Bundle STARTED: org.apache.felix.eventadmin:1.2.2
15:07:47,357 INFO [DeploymentScannerImpl] JBossOSGi Runtime started in 0.682sec

When I go to the browser and enter the url "http://localhost:8090/", this is the result - "Safari can’t open the page “http://localhost:8090/” because Safari can’t connect to the server “localhost”.". I have started the web service in the system preferences.

Please help.

Thanks in advance.
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 10202
    
166

This doesn't look like JBoss AS distribution. You probably downloaded the JBoss OSGi project which isn't the same as JBoss Application Server. Download the appropriate version of JBoss AS from here http://www.jboss.org/jbossas/downloads.html

[My Blog] [JavaRanch Journal]
Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 10202
    
166

Well, Peter already answered it here
sagar giri
Greenhorn

Joined: Nov 08, 2010
Posts: 5
Thanks for the quick reply everyone....
Its running fine now... There was another process running on the port 8083, which caused error at this spot: "Using RMI server codebase: http://127.0.0.1:8083)".
I killed that process and now it running just fine.
sagar giri
Greenhorn

Joined: Nov 08, 2010
Posts: 5
Hi,
I moved from Jboss 5.1.0GA to Jboss 4.2.3.GA as there was an error whenever I created a Topic.

There is no Administration Console in Jboss 4.2.3.GA. HOw do I create a Topic in Jboss 4.2.3.GA?

Thanks in advance.

Jaikiran Pai
Marshal

Joined: Jul 20, 2005
Posts: 10202
    
166

I would recommend that you stick with JBoss AS 5.1.0. If the topic creation is failing through admin console[1], then you can create it manual in xml files. See this JBoss Messaging documentation.


[1] Probably because of this? http://community.jboss.org/message/7992#7992 https://jira.jboss.org/browse/EMBJOPR-252
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: JBoss not running on macOSx 10.6.4