Granny's Programming Pearls
"inside of every large program is a small program struggling to get out"
JavaRanch.com/granny.jsp
The moose likes Web Services and the fly likes ws-i compliance questions Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Murach's Java Servlets and JSP this week in the Servlets forum!
JavaRanch » Java Forums » Java » Web Services
Bookmark "ws-i compliance questions" Watch "ws-i compliance questions" New topic
Author

ws-i compliance questions

Rene Ummels
Greenhorn

Joined: Feb 12, 2010
Posts: 11
Hi,

It seems the wsi-tools@ws-i.org mailbox cannot be reached.
Is the mail address still correct?


Further, I have some questions about WS-I BP 1.1 Compliance Analyzer test results. It would be
nice to get response on it.

Background:
Our requirement is to be WS-I Basic Profile 1.1 compliant for our Web Service created
from a designed WSDL (generating all the classes through JAX-WS 2.0).
We performed all the steps including generating the SOAP message traces.
I see several "missing input" entries. These have been checked manually.

Issue:
Still some questions remain for 10 of the requirements showing "missing input".
I hope I can get clarification on them.

Requirement - Question
R1014 - What could be wrong in WSDL/XSD/message that would explain this "missing input"?
R1001 - What could be wrong in WSDL/XSD/message that would explain this "missing input"?
R1031 - <faultcode>soap:Server.ProcessingError</faultcode> should be changed to <faultcode>soap:ProcessingError</faultcode>, right?
R1132 - We are compliant, we are using POST method, right?
R1112 - Why is this reported as "missing input"?
R1114 - We are only using POST, so why is this reported as "missing input"?
R2213 - Why is this reported as "missing input"?
R2712 - What could be wrong in WSDL/XSD/message that would explain this "missing input"? Something with the fault exceptions?
R2740 - Is this a fault in our solution? There is no fault element inside soapbind.
R2744 - Is this "missing input" not applicable for us?

One more thing.
In our WSDL file we have the following, does this mean we are not compliant to WS-I BP 1.1?
xmlns:soap12="http://schemas.xmlsoap.org/wsdl/soap12/"
xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/"
xmlns:soap12enc="http://www.w3.org/2003/05/soap-encoding"


Below are the WSDL and XSD contents.


kind regards,
Rene







 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: ws-i compliance questions
 
Similar Threads
Error While Testing Webservice using Web service Explorer in RAD
Error on Axis 1,4 on invoking a web service
Cannot create service instance, service 'x' not found in wsdl
Web Service message level Encryption Decryption through public and private key
How to access byte array web method