aspose file tools*
The moose likes Struts and the fly likes Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Frameworks » Struts
Bookmark ""jsessionid=..." occassionally appears on my URL and sometimes I don, is that a bug ?" Watch ""jsessionid=..." occassionally appears on my URL and sometimes I don, is that a bug ?" New topic
Author

"jsessionid=..." occassionally appears on my URL and sometimes I don, is that a bug ?

Artemesia Lakener
Ranch Hand

Joined: Jun 21, 2005
Posts: 162
I have checked my browser by using "isREquestedSessionIDFromCookie()" method and it returns TRUE so my browser is supporting cookies. Now the confusing part is -- Sometimes I don't see any "jsessionid=xxxx" but sometimes I see "jsessionid=...", it looks like quite arbitrary, sometimes on this page I see it, but not on next page, and vice versa, the application works fine though. I am wondering if anybody knows the reason for this. Is this a bug coming from my application ? But I really don't do any session tracking here as struts handles that for me.
Artemesia Lakener
Ranch Hand

Joined: Jun 21, 2005
Posts: 162
The interesting thing is even after I block the cookies on my browser, when I get to the beginning JSP page, first I saw "jsessionid=.." when clikc "submit" to go to the next page, but when I click "back" to the first page, and then click "refresh" button, then click the submit, this time the "jsessionid=..." disappeared. why ? AM I supposed to see it because I have blocked the cookies ??
Tokunbo Oke
Ranch Hand

Joined: Sep 09, 2003
Posts: 57
This is perfectly normal. Read page 66 of Struts in Action, Husted et al (in any bookshop) for details.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: "jsessionid=..." occassionally appears on my URL and sometimes I don, is that a bug ?