aspose file tools*
The moose likes Swing / AWT / SWT and the fly likes Help with JFace Wizard. Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Java 8 in Action this week in the Java 8 forum!
JavaRanch » Java Forums » Java » Swing / AWT / SWT
Bookmark "Help with JFace Wizard." Watch "Help with JFace Wizard." New topic
Author

Help with JFace Wizard.

Aditya Bhasale
Greenhorn

Joined: May 16, 2009
Posts: 6
Hello all,

I'm developing a JFace wizard plugin. The wizard has a total of 5 pages. The problem is, the buttons, combo boxes on wizard are not receiving clicks. At first execution, it run successfully. Later it stopped working.
I can't figure out what's wrong. There's no problem in the code.

I used WindowBuilder to design GUI for wizard pages. I have two eclipse installations. The one with WindowBuilder runs the wizard correctly, while the one not containing WindowBuilder refuses to respond clicks.

Why is that happening?

The WindowBuilder adds com.instantiations.designer.jdt.fragment_8.1.0.r36x201010220706.jar in plug-in dependencies. Is it making the wizard plugin responsive?

Please help!!!
Eric Clayberg
author
Ranch Hand

Joined: Sep 24, 2004
Posts: 63
That plugin is part of the WindowBuilder development environment and should not be part of your plugin dependencies (that is not added by WB to your dependencies).

It would not have any effect on this issue either way. I am guessing that you have something else that is broken in your non-working environment.


Eric Clayberg
Software Engineering Manager
Google
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Help with JFace Wizard.
 
Similar Threads
How to Pass value from one one wizard page to the other in JFACE
Help Jface/SWT for Plugin development of Eclipse
2page custom plugin wizard using combo box
Next ,Finish button !!!!
Setters not being called on bean when navigating away from JSP page