aspose file tools*
The moose likes IDEs, Version Control and other tools and the fly likes Eclipse Debugger : Hot Code Replacement not working Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login
JavaRanch » Java Forums » Engineering » IDEs, Version Control and other tools
Bookmark "Eclipse Debugger : Hot Code Replacement not working " Watch "Eclipse Debugger : Hot Code Replacement not working " New topic
Author

Eclipse Debugger : Hot Code Replacement not working

Ravi Kiran Va
Ranch Hand

Joined: Apr 18, 2009
Posts: 2234

Hi ,
I am not able to work on Eclipse debugger Hot Code Replacement , i have enabled the option of Build automatically as recomended , I am using Java 5.0 as my JVM version .

Below is my code



I put up an Break Point at the line "Stopping At Break Point" its stopping there , and when i sopln added Newly added Line , it is showing an error in pop up message as "Unable to remove old stack frames "


please suggest .



Save India From Corruption - Anna Hazare.
Ravi Kiran Va
Ranch Hand

Joined: Apr 18, 2009
Posts: 2234

Hi ,

I have found that Hot code replacemenet is not working for static methods , but for normal methods HCR is working fine .

Thanks .

Tim Holloway
Saloon Keeper

Joined: Jun 25, 2001
Posts: 16250
    
  21

Hot code replacement may or may not work, depending on rules that I don't think anyone actually formally defined.

We've had a discussion or 2 on this topic in the past year or so. You might find it useful to search for them.


Customer surveys are for companies who didn't pay proper attention to begin with.
 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Eclipse Debugger : Hot Code Replacement not working