This week's book giveaway is in the Mac OS forum.
We're giving away four copies of a choice of "Take Control of Upgrading to Yosemite" or "Take Control of Automating Your Mac" and have Joe Kissell on-line!
See this thread for details.
The moose likes Web Services and the fly likes Netbeans Axis2 Web Service won't autodeploy Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


JavaRanch » Java Forums » Java » Web Services
Bookmark "Netbeans Axis2 Web Service won Watch "Netbeans Axis2 Web Service won New topic
Author

Netbeans Axis2 Web Service won't autodeploy

Nicola Ace
Greenhorn

Joined: Sep 27, 2010
Posts: 8
Hello guys.
It's my first time with web services and i have followed this Netbeans tutorial to implement them:
http://netbeans.org/kb/docs/websvc/intro-ws.html

I have installed axis2 plugin and the server is up and running.
I have made the web services of the example and the AxisHello.aar file is created and is incorporated in the axis2.war file.

The problem is that i have to delete the axis2 directory each time to make the web service work or deploy it "by hand".
Doing that the war file is unpacked and the .aar file is well inserted in the services directory.

There is a way to made it "automatic"?
Otherwise i have to delete the directory each time i make a change to the code of the web service.

Hope someone can help me.

PS. Forgive my bad english
 
GeeCON Prague 2014
 
subject: Netbeans Axis2 Web Service won't autodeploy