aspose file tools*
The moose likes Web Services and the fly likes Cannot create service instance, service 'x' not found in wsdl Big Moose Saloon
  Search | Java FAQ | Recent Topics | Flagged Topics | Hot Topics | Zero Replies
Register / Login


Win a copy of Spring in Action this week in the Spring forum!
JavaRanch » Java Forums » Java » Web Services
Bookmark "Cannot create service instance, service Watch "Cannot create service instance, service New topic
Author

Cannot create service instance, service 'x' not found in wsdl

Avinash Annamaneni
Greenhorn

Joined: Nov 21, 2010
Posts: 7

Hi all,

I have a problem in accessing a web service, please help me out

Task : I have a WSDL with me, which i am able to open and see it (ie. i have network access) , i have to call the methods in the wsdl

What i did : I used that wsdl to create a client in Jboss Developer studio 3.0 (ie. create a Dynamic web project then right click on it and select create web service client,give wsdl and then client it gets created)

But when i am trying to run the client it says

Exception in thread "main" Cannot create Service instance, service {urn:ucsvitriawebservice:Vitriawebservice}ucsvitriawebservice not found in the WSDL http://localhost:8080/ucsvitriawebservice/Vitriawebservice?wsdl
at com.sun.xml.internal.ws.client.ServiceContextBuilder.build(Unknown Source)
at com.sun.xml.internal.ws.client.WSServiceDelegate.<init>(Unknown Source)
at com.sun.xml.internal.ws.spi.ProviderImpl.createServiceDelegate(Unknown Source)
at javax.xml.ws.Service.<init>(Unknown Source)
at vitriawebservice.ucsvitriawebservice.Ucsvitriawebservice.<init>(Ucsvitriawebservice.java:45)
at vitriawebservice.ucsvitriawebservice.clientsample.ClientSample.main(ClientSample.java:10)


but the service is present in wsdl...

Here is the wsdl file



I tried creating the client using ClientGen and then tried to acces the method then it is working, but in this way we are dependent on weblogic.jar and webservices.jar (ie. these jar's must be in the classpath)

I have to acces the web service from within the JBOSS server so i am not allowed to proceed in the above way.

Help me out please...

Thank you

 
I agree. Here's the link: http://aspose.com/file-tools
 
subject: Cannot create service instance, service 'x' not found in wsdl